Raspberry Pi gpio missing in Arduino ide Programmer list


#1

I am using an R Pi 2 using a standard, updated Raspbian image with the Arduberry , I followed the Dexter Industries instructions on installing the Arduberry software and initially it indicated an error on line 8 regarding user/bin/realpath, but a few seconds later the download process kicked in and ran. At one point after it appeared most of the required programs were installed, the screen simply went dark and stayed that way. I rebooted the Pi, and when it came up the Arduino ide was in the Programs listing. However, when I opened the ide and selected tools->programmer, the Raspberry Pi gpio selection was missing. I then rebooted the program and repeated the original install process. This time, the install program ran very quickly and got to the reboot question, which I answered yes to. However, after rebooting, the Raspberry Pi gpio selection is still missing in the Arduino ide Tools->Programmer box. Any ideas on how to fix this are appreciated.


#2

Hi @randyholl,

I’m not sure whether you’re using the Raspbian For Robots image or trying to install Arduberry on your own from a fresh Jessie image.

Also, I’m now creating an issue on github on this matter, so we don’t forget it somehow.


Anyhow, can you try using our image instead and see if works?
Here’s a link to it:


Please keep me updated on how things evolve on your side.

Thank you!


#3

Robert,

I was previously using a standard Raspbian image that came with my R PI 2B+, which was purchased through AdaFruit. I tried loading your Dexter Industries Raspbian for Robots image. While it copied to the microSD card successfully, when I tried to boot the PI, it ran through two pages of setup and then the screen went blank (output was to an HDMI monitor) and the monitor shut down due to no signal from the PI. So, now I cannot make it work with either image. Any advice is appreciated at this point.

Randy Hollingsworth
Cedar Rapids, IA


#4

Robert,

Any further thoughts on my issues with the Arduberry that we were discussing (see below)?

Randy


#5

Hi @randyholl,


when I tried to boot the PI, it ran through two pages of setup and then the screen went blank (output was to an HDMI monitor) and the monitor shut down due to no signal from the PI

Thinking again, your issue is similar to what was discussed in the following thread:

I’m thinking that your Arduberry which sits on top of your Raspberry Pi still has the black foam. This black foam is electrically conductive, so it may short the pins between them.


Also, if you burn a fresh Jessie image on your micro SD Card and plug it in your Raspberry Pi, does it boot up?
Here’s a link to a fresh image of Jessie distro.


Thank you!


#6

Robert,

Thanks for the suggestion. As a result, I have good news and bad news. First, removing the conductive foam did indeed solve the problem with the PI shutting itself down. However, as I followed the steps for getting started with the Arduberry on your web site, I encountered what appears to be a serious error once I tried to run Blink. I believe all of the settings are correct, including board, port and programmer. And I am using the “compile using programmer command” in the file menu to upload the sketch.

However, while the program appears to compile OK, when the PI tries to verify the data written to the flash card, I receive an error, specifically- avrdude: verification error content mismatch, and then a memory location where it did not read back the correct info. I have checked a number of web sites on this error, and some say that it represents a problem with the board that is not fixable by the user, others prescribe the use of a third party software to fix it. Since I am dealing with the unique Arduberry version of the Arduino, I need to know if there is a Dexter Industries recommended fix for this issue.

Thanks so much for your assistance.

Randy


#7

Hi @randyholl,

I’m happy to hear we’ve solved the initial issue.


Heading over to the next one, I’m not sure I’m getting the following phrase. I quote:

to verify the data written to the flash card

Are you referring to the Atmel chip that resides on the Arduberry?

More details on the error you’ve encountered can be very helpful for us.
So could you share with us a screenshot with what you get when you press the Compile button?


Also, could you try burning a new image of Raspbian For Robots again on your micro SD Card and then try flashing the Arduberry the same way?


Thank you!


#8

Robert,

Attached is the screen shot you requested. Also, I am assuming that the board selection for the Arduino IDE should be set to Arduino UNO – it does not say anywhere in your instructions for the Arduberry what that should be set to.

Randy


#9

Robert,

I have repeatedly tried compiling and uploading the blink sketch. At one point, it did actually compile, upload and work correctly. However, now I am getting the error message in the new screenshot repeatedly, basically that the AVR device is not recognized and the sketch can’t be uploaded. The screenshot is attached. At this point, the Arduberry board I have is simply not usable and I am hoping you can provide a fix.

Randy


#10

Hi @randyholl,

Can you tell us if you have anything attached to your Arduberry?
If you do have, could you please remove them from your Arduberry and then try again the upload process?

Thank you!