Raspberry Pi issue with wifi

I’m running Dexter on a Raspberry Pi3 and trying to access it fron a Raspberry Pi4. When I select the wifi network I see a message saying that wlan0:GoPiGo has been disassociated . I can access the GoPiGo from other computers without a problem. I can only assume it’s because there’s no password (I can access my other password protected SSIDs) .
Curious if anyone else has experienced this.

I’ve reinstalled DexterOS (just to be sure )

1 Like

I’m having trouble following exactly the steps you are taking and where you are seeing the disassociated msg, and what the hostnames, OSes, and user interfaces you are attempting.

  1. GoPiGo-RPi3-DexterOS(Dex)-WiFi
  2. (to RPi3)WiFi-RPi4-(OS? Hostname?)-Hardwired Display? or dual WiFi adapters?
  3. (to RPi3 GoPiGo)WiFi-Laptop-Browser(http://dex.local) “without a problem”

Sorry about that.

  1. From - >DexterOS 2.5 on Rpi3+ - this all seems to be working fine when connected with other devices (Mac and IPAD)

  2. Raspian(Buster) on Pi4 - the client - this is where I’m having the problem trying to connect to Dexter wifi.

To be honest, I’d prefer to have Raspian for Robots running as the server on my RPi3+ but I really want to allow my son to use Bloxter which, from what I understand, doesn’t come installed with Raspian for Robots

Does the Pi4 have a keyboard and HDMI wired display attached?

I have tried what you’re describing: Connect via wifi to GoPiGo3 running DexterOS V2.5 from Pi4 running Buster.

No issues for me, all works as expected.

In your first post you said you’ve reinstalled DexterOS on the GoPiGo.

Have you tried reinstalling software on your pi4? Can you successfully connect to other wifi networks from you pi4?


1 Like

Hi Kevin,

I haven’t tried reinstalling the software on the rpi4 - that would be th enext logical step, I agree. I’ll try that when I get a chance - my son is using the rpi4 for his school work right now so I don’t want to disrupt that … :slight_smile:

The rpi4 does have keyboard, mouse and monitor attached -

Let me try and re-install raspbian on the rpi4 and take it from there - really appreciate the help .

If there is a way to install Bloxter on Raspian for Robots I’d be all set.



1 Like