Raspberry Pi Wifi Adapter Problem


#1

I just received the Raspberry Pi WiFi Dongle, from Dexter, and I’m unable to get it to function. It is not showing up on the “lsusb” when I connect it; even booting the Pi with the dongle connected. All info about installation states I should see it when I use the “lsusb” routine. As a test I plugged in a Bluetooth dongle and it showed up on the list.
Please Help.
Thanks Brian


#2

Hey Brian, it sounds like the wifi dongle isn’t working then. If it’s not showing up on lsusb or ifconfig, we can try to send you a replacement.

Can you contact Amber through this link: dexterindustries.com/contact.html and she’ll set you up with a replacement.


#3

Thank you John, I’ve posted my request.
Brian


#4

Okay, I’m perplexed. I received the replacement Wifi adapter; thank you very much for the rapid turn around. However like the first on when I plugged it in and ran “lsusb” it didn’t recognize it. I found an old Netgear adapter and tried it and the Pi recognized it. I discovered a D-Link adapter and it also saw it when I plugged it. I plugged the Pi dongle adapter into my Windows laptop and it at least listed on the devices.
Is there some setting on the Pi that I need to check?
Thanks again, Brian


#5

Hey Brian,
I’m glad we responded with that quickly. I had to write something quick because I was stuck behind the great firewall and didn’t have full access to the internet.

Thinking about this a little more, can you tell me what image you’re using, and what version?

We found that with some of the wifi dongles the drivers are not properly available. I can walk you through installation if that’s the case. Because we’ve replaced the hardware once, odds are there’s something missing on the software side.

Let me know what version of the image you’re using and how you got it setup. We’ll figure something out.


#6

I’m running the Raspian kernel 3.18. It was loaded using the NOOB’s install downloaded from the Raspberry site. Now it seems I have a more pressing issue. I booted up the Pi with the dongle just to see one more time if the Pi could see it. It didn’t however as I was reaching over to respond to your question, the Pi suddenly went into a reboot, but instead of the desktop, I got the large multi-colored window on the monitor that flashed on and off for a few times and then the screen went blank. The green LED is flashing rapidly. If I power off the Pi and turn it back on, the monitor remains blank, and the green LED starts flashing rapidly again. Okay, the mystery gets even more weird. I was powering the PI from a 9.6volt battery running through a UBEC “hextronik” power regulator outputting 5.2Vdc. This was connected to pins 1 & 3 on the board. Most of my experimenting has been done with this setup. Just as a trial, I disconnected the battery supply and plugged into the microusb connection with a phone charger, as outlined in the “manual”. The PI booted up with no issues and seems to operating okay. I checked the voltage on the battery and it was reading 5.2Vdc. Any thoughts as to what I’m doing wrong. By the way when I got the PI to boot up again I plugged in the Wifi dongle just to see if it would recognize it. No luck.
Your thoughts and ideas are most welcomed.
Thanks Brian


#7

Aha, I think I see what’s going on. Since you installed the image on your pi with Noobs, the drivers for the wifi device aren’t there.

I’m not sure what happened with your reset. The power configuration is a little different; powering your pi through the 1&3 pins won’t offer you any protection from power spikes. I would recommend using either one of our boards or using a USB device.

As far as the dongle goes, you’re missing the drivers for the wifi device. We started seeing this problem with some of our wifi dongles when the supplier started shipping with new firmware. There are two posts that will walk you through correcting the problem:

http://www.dexterindustries.com/forum/?topic=wifi-driver/#post-4466

http://www.dexterindustries.com/forum/?topic=wifi-driver&paged=2#post-4483

Can you let us know if this helps?


#8

John,
Thank you for this information. I tried the second suggestion first, but unfortunately it failed to connect; it kept giving me a “connection timed out” message. And I ran out of time. I’ll have more time later this week to work on this. I noticed a reference to “Raspian for Robots”. Is this a version of Raspian that you offer and if so how can I get a copy?
I should have an update later this week on my endeavor to resolve the dongle issue.
Again thank you so much for your help.
Brian


#9

Hey Brian, I can only imagine the frustration. Thanks for working through this!

Yes, indeed, Raspbian for Robots can be downloaded from sourceforge. The link: http://sourceforge.net/projects/dexterindustriesraspbianflavor/

You may be getting a “connection timed out” because you’re not connected to the internet. If you run
ping google.com
do you get a response or a timeout? If you’re not connected, Is it possible to connect your Pi to your router with an ethernet cable?


#10

John,
I’m determined on this, ha, ha. As to the “connection timed out” the Pi was connected to the router with an ethernet connection. That was the reason for the 'Raised Eyebrows"; since I was “hard connected” couldn’t understand why it was timing out.
We will over-come!!
Brian


#11

Alright, praise GOD it is working! This update is coming to you via the Pi connected wirelessly! I used the image you suggested and booted up the Pi. Checked for updates, powered down, and rebooted with the Wifi dongle installed. I was up and running in no time. Thank you very much for you help!!
Just made my weekend!
Brian


#12

That’s fantastic, great to hear!