Raspbian For Robots on RPI Zero W doesn't work


#1

I have Raspbian Jessie already on my Raspberry Pi. Do I have to delete that off of the Pi in order for Raspbian for Robots to work? Because I followed all the instructions to download Raspbian for Robots on my SD Card but when I plug it into my Raspberry Pi Zero W, the activity light blinks then turns off, which I think is a sign the SD card content is faulty.


#2

No, you do not need to erase anything from your SD card. The software you use to write the image to the card should take care of that.

Others have had issues with Raspbian for Robots on the Pi Zero W. However you said the activity light turns off, have you tried plugging your pi in to a monitor or TV? Note you’ll have to plug it in prior to powering it on.

Now assuming that Dexter Ind got Raspbian for Robots to work on the Pi Zero W, and that it’s not booting for you there are some things to try. Either way though it couldn’t hurt if you wanted to try.

  • Try etcher.io Etcher is easy to use and validates that the image was successfully written. It may work better than wim32 disk image writer. Instructions for using it are here.
  • Try rewriting the SD card. Perhaps the table shifted or something and the SD card didn’t get properly written. Sometimes it can fail. You could also try redownload info the image. I have had failure even with the Pi3 and normal Raspbian, the steps I just gave worked, and the image booted.

If you can’t get Raspbian For Robots to work that’s OK. You can use Dexter One’s robots with Raspbian. Go to GitHub.com/DexterInd and find your robot’s repository. The readme should explain how to install. If you have any trouble just ask.