Raspbian_for_robots_update.py Errno 2 No such file or directory


#1

GoPiGo3 R4R V9 last updated 2018.07.05
Started getting strange TypeError messages on programs that used to work. So tried to update…

Attempted update 2018.07.08
Dexter_Software_Update_log_2018_07_08_17_44_17.txt:
"Script started on sun 08 Jul 2018 05:44:17 PM CDT
python: can’t open file ‘/home/pi/di_update/Raspbian_for_robots_update.py’: [Errno 2] No such file or directory
Script done on Sun 08 Jul 2018 05:44:17 PM CDT

The /di_update/ folder exists, but it’s EMPTY.

Now how do I update??

JHP


#2

The following two lines of code will reinstall the appropriate files. Weird that they’re gone, though.

cd /home/pi/di_update
sudo git clone https://github.com/DexterInd/Raspbian_For_Robots/

Cleo


#3

Cleo,

Thanks for the response! Update worked ok following your directions.

Each time I do a Dexter update, I have to reclaim ownership of the Dexter directory sudo chown -R pi:pi Dexter or I can’t copy or modify anything.

Once that’s done, I’m OK. Just annoying to have to do it every time I update.

Still getting weird TypeErrors since the update to raspbian stretch, particularly with the ultrasonic sensor.

Went back and tested on one of the supplied example programs, (grove_ultrasonic.py, attached) so the code should work ok, right?. It did before.

But it doesn’t. I then modified the code slightly to print out which error was being excepted, and it turned out to be TypeError.

The shell script is attached. Did we loose something in the Dexter utilities with the stretch update?

Jim Phelan

grove_ultrasonic.py (1.89 KB)

grove_ultrasonic_py_errors_Shell.txt (1.12 KB)