Raspbian for Robots Wifi Dongle


#1

Hi,

I am now using Raspbian for Robots together wit the GrovePi + and a Raspberry 3.
Because the wifi connection using the standard on board wifi is a bit to weak I added a wifi dongle to the system.
The on board wifi is called wlan0.
When I add the dongle to the board it is recognized at wlan1 and after a while it is picked up and connects to my home network at a different ip address.
So far so good…

However, when I restart the system it does not find the dongle and the wlan1. When I unplug the dongle and put it in after a while there are chances that it is recognized again.

My /etc/network/interfaces file looks like:

source-directory /etc/network/interfaces.d
auto lo
iface lo inet loopback
auto wlan1
auto wlan0
iface eth0 inet manual
allow-hotplug wlan1
iface wlan1 inet manual
_ wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf_
allow-hotplug wlan0
iface wlan0 inet manual
_ wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf_

If I leave wlan0 out of this it does not work.
My wpa_supplicant.conf is OK because it functions with wlan0

On the internet I found that with Jessie I had to modify another file called /etc/dhcpcd.conf
I added the following lines to it:
interface wlan1
inform 192.168.0.199

Any idea how I can solve this problem?

Also on the Raspbian for Robots there is no true VNC. Is this correct?
When I open a session on my raspberry directly with a display monitor connected, I would like to have the same session and screen when I use VNC. The reason is that I run a program with status reports in XTerminal. This is always started from the Raspberry directly. With VNC I would like to open the same session and have an exact mirror of what happens in the session on the Raspberry directly, preferable with the same screen resolution.
Thia worked fine on a normal Jessie install but is not functioning with Raspbian for Robots.

Any ideas?

Kind regards,
Freddy


#2

Try using the gui, and check out this tutorial on the pihut:
https://thepihut.com/blogs/raspberry-pi-tutorials/16018016-how-to-setup-wifi-on-the-raspberry-pi-raspbian

It’s normal that there isn’t a normal vnc. To do this you’ll need to install realvnc Even though it’s not the “real” raspbian it essentially is so you can get realvnc. Or if you don’t want to install just use raspbian. Then install your grovepi on raspbian, it’s not that hard.


#3

Hi Mr. GrayKevinB,

Thanks for your reply but of couse I tried all this and wlan0 is OK, but an additional wlan1 causes the problem.

I came along another problem:

I have a python script to run at reboot.
I use crontab for it.

The program runs fine.
However, for one obscure reason, the wifi network is never found.
In the raspbian desktop that starts later, than the wifi is working but my python script does not see it. Maybe this is because it is running in another session or so.
Can you or anyone provide any assistance?

Kind regards,
Freddy