Raspian4Robots GoPiGo3 download/flash to microSd card won't boot

Downloaded latest image. GoPuGo3 will turn on, but no antenna light, If ethernet cable attached the http://dex.local brings up the VNC/sh screen and it works. But no way to get an IP, so when ethernet is removed VNC fails.

Decided to take standard Raspbian stretch card placed it in the GoPiGo3’s pi3 and hooked up screen, keyboard & mouse (Had to take one wheel off). Got usual interface. Then used the 2 curl commands in the latest documentation to load in the gopigo3 and sensor libraries.

Immediately the antenna light came on and all facets of the interface worked. VnC works the system well using an automatically grabbed IP address.

I actually tried the download from the Dex website 3 times, used etcher to flash the microSD with several cards – all failed to boot either of 2 GoPiGo3s.

BTW, The DexterOS downloads work OK – except for the Bloxter bugs & the weird translations to Python. The Jupyter Notebook modifications are a bit buggy also. Reported a few, little interest. Troops very busy dealing with the merger. Tends to get your attention. Been there.

Good workaround is to just take a “normal” raspbian card and download the gopigo3 and sensor libraries as per instructions. Will save you a lot of time and angst.



This is EXTREMELY interesting!

The only time I’ve had trouble like that was using an off-brand micro-SD card, and that was with plain-vanilla Raspbian direct from the Pi site itself.

Did/do you verify checksums? If you do most of your downloads on Windows, Slavasoft has a nice freeware utility called “hashcalc” that is well worth the download.

Have you checked your battery voltages?

As everyone else here knows, I had absolute fits when I first started because I foolishly believed that name-brand alkaline batteries were as good as the ads said.

What batteries should I be using for the GoPiGo?

Using better, higher capacity NiMH batteries solved my problems