readAnalog() - Errno 5


#1

Hi - I’ve made some good progress with my Pi2 and GrovePi+ today but now I’ve hit a wall.

I can’t read from any analog sensors on any A0-2 ports.

When I try any call to analogRead(n) I get “[Errno 5] input/output error”

I’ve tried updating the firmware to the latest from github, but it’s still not working

I’ve stripped my code down to the bare bones:

import grovepi
grovepi.pinMode(0, “INPUT”)
i = grovepi.analogRead(0) ## Error here
print i

I’ve tried this with different pins (0-2) and different sensors (light sensor and UV sensor) with the same results.

I have I2C for the Grove TH02 sensor working well and dgital output for the LED is working fine, just stuck on the analog inputs.

Any suggestions??


#2

Hi,
I have the same problem


#3

I get the same issue, has anybody found a resolution to this or is it defective hardware?


#4

Hey Thorgrimm and jbb352, there may be an issue with the Analog ports on the GrovePi. I would suggest asking for a replacement from whom you bought them. If you bought them from us, please contact us through our contact link at the bottom of this page.

Karan and I are working to improve the testing process we have in place for producing these boards. We need to know more about the problem though. Can either of you post some high resolution pictures of the boards and the ports? We’d like to know if it’s a chip problem or a soldering problem. Do the leads on the ports look like they’re well soldered?

Thanks for your help with this. I’m sorry for the inconvenience and we’ll try to make this right.