Remote Control command issues - bloxter

dexteros
remote

#1

HI All - had success with the remote control for about a day and now this issue has appeared.

Looking at the value for the IR sensor on AD2, when we press Ok button the value displays as 8.
4 = left
6 = right

etc.

Tried two different remotes, two diff IR sensors on two different GoPiGos. Tried with distance sensor disconnected and connected.

Any ideas or help is appreciated.

Thanks,

Rod


#2

Hi Rod,

So there’s something coming from the remote as long as value 8 gets displayed.

In the meantime, can you tell us what GoPiGo are you using (GoPiGo3/GoPiGo2) and what version of DexterOS you are running? The latter can be found by looking at the top right corner in Bloxter.

Also, do you think you can instantiate a Remote object like here and try and read the sensor a couple of times while you are pressing the remote’s buttons?
https://gopigo3.readthedocs.io/en/master/api-basic/sensors.html?highlight=remote#easysensors.Remote

Thank you!


#3

Yes - at least we read an output from the remote.

I’m using the shipping version of Dexter 2.2.0 on a GoPiGo3.

I don’t know enough to instantiate through Python. However, here’s the full mapping through bloxter.
1 nothing
2 up
3 nothing
4 left
5 ok
6 nothing
7 nothing
8 down
9 nothing

  • 1
    0 2

3

up 5
left 7
ok 8
right 9
down 0

Note that I have tested this on two separate robots with two separate remotes and IR receivers.

Any ideas are appreciated.


#4

Hi @rpmteacher,

That’s odd. It’s the first time hearing a problem with the remote control on the GoPiGo3. Have you tried a new set of batteries?

You are saying it worked for a day and then it stopped. Since you’ve flashed the image a couple of times, then it doesn’t make any sense for the remote to not work, unless there’s something bad going on with it.

Let me know if it works when you get your replacement remote.

Thank you!