Renaming GoPiGo Robots


#1

We have six GoPiGo robots that we need to rename so that we can have students in the Computer Lab running all six at the same time. I just downloaded the Notepad ++ as suggested in the video. While watching the video I noticed that the Rasperri Pi was disconnected from the GoPiGo board when updating the name. Do I need to do this? The robots are already fully built. Thank you.


#2

No, doesn’t matter. By the way are you using cinch? Depending on what your doing it may help. Here is a thread that may answers the question of using multiple robots with cinch. http://forum.dexterindustries.com/t/using-the-gopigo-in-the-classroom-with-cinch/2377/4


#3

Hi @jgallagher,

Just to confirm, are you referring to this video?

If yes, then you don’t have to have the Raspberry Pi disconnected from the GoPiGo. But you will have to remove your SD card from the Raspberry Pi(Remember to remove the SD card after switching off the power supply) and make the changes as suggested in the video and plug the SD card back into the Raspberry Pi and boot it.

-Shoban


#4

OK - I put the SD card into my computer like the video said, and there is no file called Hostname when I put it in the computer as a disk. I tried this on two of the six SD cards for my GoPiGo robots. Help!


#5

Odd. Try renami g it on the pi itself. Here’s a complete tutorial by dexter Ind. https://www.dexterindustries.com/howto/change-the-hostname-of-your-pi/

Hope this helps.


#6

Hi @jgallagher ,

Yes, if you don’t have a file named hostnames by default, then you will have to create a new text file named hostnames. To create a new text file goto your sd card, right click and select New and then select Text document. Then change the name of the text document to hostnames without any .txt extension. It will ask you to confirm, click yes. Then open the hostnames file and add the desired name in it as shown in the video.

Please let us know if this helps,
-Shoban


#7

I followed your instructions, but when I connect the GoPiGo to the laptop to complete the setup; the lights will not go on at the ethernet connection. I kept the name as dex on the one robot and was able to run through the process of connecting initially. I think renaming this card will now not let the robot connect to the laptop.


#8

Hi @jgallagher,

Can you tell us which version of cinch you are using. I tried it with the latest version of cinch and I changed the hostname and connected to the GoPiGo network and I still see the ethernet working and the Leds blinking.

You can find the latest cinch image available here.

-Shoban


#9

I am not sure which version I am using. I am using the SD card based on
how Dexter Industries sent them to me. What exactly do you want me to do
here? Do you want me to connect the Rasperri Pi to the computer via the
ethernet? I appreciate you helping me with this, but I need a little more
guidance as to the steps I am to take here. I have six robots that I can’t
get connected and I am becoming very frustrated. Thank you for helping
me. I really appreciate it!


#10

Hi @jgallagher,

I apologize for the delay in replying. Can you follow the instructions given here under How to Get cinch, download the latest cinch image and install it. After installing if you continue to have the problems on using the latest image that I have directed you to, please let us know. If you find it difficult to install a new image, you can update your existing image to the latest by following the instructions given here under How to update cinch.

Please let us know how it goes, we will be happy to help you out, sorry once again about the delay.

-Shoban