Robot's wheels do not respond


#1

I finished the physical construction of my GoBox GoPiGo and when completing the software construction I found the wheels do not move. I ran the GoPiGo troubleshoot, but I do not know how to attach the log to this post. I also checked the version text and it stated version v 6.6
I have checked the GoPiGp board and it states version 16.0. I am getting frustrated as this is the second problem I have encounted with my GOBOX - the first was no microSD card included with the kit. You corrected that mistake by shipping me a new card. Now this problem.

My assumption is that I may have a mismatched set of hardware/software?


#2

Hey larrymittman, at the bottom of this page, you’ll find the the “choose file” button. That should allow you to choose the file you want to upload. When you press “Submit” the file you selected will upload.

You don’t have a mismatched set of hardware or software (I know your case quite well). However, I can’t really begin to troubleshoot the problem until you send me that script.

Kindest and warmest regards,

John


#3

Also, here’s a picture of how to attach a script to your forum post. The button is shown in the attached picture.


#4

I’m sorry, I did not make myself clear. The reason I have attaching the log file is that I am connected via Putty and writing via Windows 7. I do not know how to transfer the log file to my laptop so as to attach it to this message. I tried startx but it failed with module g2d_23 not found. Any further ideas?


#5

I was able to connect my thumbdrive and copy the log file. Here is the log file from the GoPiGo troubleshooting.
Thank you.


#6

Larry, thanks, that helps a lot. We can see the Pi isn’t talking to the GoPiGo board. Can you send us a picture or two of how you have the Pi setup? In particular, how the Pi and the GoPiGo board are attached, and how you’re powering the Pi and GoPiGo.

Thank you again for your patience.


#7
I’m sorry, I did not make myself clear. The reason I have attaching the log file is that I am connected via Putty and writing via Windows 7. I do not know how to transfer the log file to my laptop so as to attach it to this message. I tried startx but it failed with module g2d_23 not found. Any further ideas?

One thing to note: if you’ve logged in via putty, you won’t be able to run startx. Putty’s a text-based program, and the desktop is a graphical program. What you can do is login to your desktop at “http://dex.local” and choose VNC to view the desktop. I think you might have already figured this out though!


#8

Per your request, I have attached pictures from each side - top, bottom, front, back, right and left. I removed the canopy to get better shots.


#9

Here are the right and left views.


#10

Hi Larry, Can’t see anything wrong, it looks like you’ve set it up correctly. It’s hard to say what’s going on, but it appears that the board isn’t communicating with the Raspberry Pi. I’m not sure what’s going on, but I think our best next step is to try to replace the electronic board. I’ve just set up a shipment to you through Fedex, you should be getting an e-mail with tracking information asap.


#11

John,
I received the replacement package and was surprised! I only expected the replacement GoPiGo2 board, not the complete starter kit! Thanks!
However, When I tried to access the icon for troubleshoot and demo, I got an error that Can not copy user’s Xauthorization file. I can not access the update DI software icon either - same problem. Now what do I do>
Thanks for your help.


#12

Hi Larry,

This is an interesting one, we haven’t seen it. Have you made any changes to your user name or any changes to the operating system? Have you installed other software on the Raspberry Pi since we last spoke? Are you running it in a different way than you were previously when the software wasn’t throwing this error?

John


#13

No to everything. Maybe I need to reload the DI software? If so, can you give me the Bash script that I can run via the LXterminal? Just a thought.


#14

Another thought - could the file be corrupt and need to be recreated on the user side?


#15

I have attached a screen shot (snippet) of the error message just so you can get a better idea of the actual problem.


#16

Hey Larry, thanks for your patience and thanks for sending the screenshot.

I have a few thoughts. This might be because an update was cut off before it finished. Could that have happened?

First, I would try updating the software. The problem might resolve if you run the update program, clicking on “DI Software Update” and click on the software update option. Are you able to run the update or does that give the same issue? If it gives a new issue, can you upload a screenshot?

The nuclear option is to reburn the software. You can do this with these directions: http://www.dexterindustries.com/howto/raspberry-pi-tutorials/install-raspbian-for-robots-image-on-an-sd-card/


#17

John,
In answer to your first question: Yes, I think you are right. I am pretty sure that that an update I was attempting (to try to fix my first problem) cut off before it completed.

I am not able to run the update - it gives what looks at first like the same error message. However, when examined closer, the errors are for the same problem but give slightly different messages. I assume that is because they come from different compilations and thus different addresses and calling structures. Here are the two messages shown in better resolution.

Finally, I also tried the Scratch icon and it worked perfectly! I was able to run the demo successfully through it. The GoPiGo2 performed exactly as the demo predicted.

Based on this outcome, I do not think I need the “Nuclear Option”, I just need to recompile the two routines. What do you think? Now, how do I go about doing that?
Thanks


#18

Hey Larry, great to hear the GoPiGo is working. That’s fantastic news!

I think there might have been a file permission changed during the update that was cut off. Can you run the following command:

ls -la ~/.Xauthority

And let us know what yours returns? When I run it on my functioning Pi, it get the following:

pi@dex ~ $ ls -la ~/.Xauthority
-rw------- 1 pi pi 201 Jan 14 06:28 /home/pi/.Xauthority

That “rw” tells you who has permission to run these things.

Also, another possibility is that the permissions on the start scripts were never changed back. Can we check those as well; if I run:

ls -la /home/pi/Desktop/GoBox/Troubleshooting_GUI/Troubleshooting_Start.sh

I get back:

-rwxr-xr-x 1 root root 414 Nov 10 11:37 /home/pi/Desktop/GoBox/Troubleshooting_GUI/Troubleshooting_Start.sh

What does your Pi return?


#19

John,
Thank you VERY MUCH!! Your last reply gave me all the information I needed to fix my problem. When I ran the directory listing for ~/.Xauthority, it showed the owner and group to be root not pi. I ran chown and chgrp to change them back to pi and everything worked. I even ran the DI_software update. I have attached my console log and the Troubleshooting log to show you all the results.

Once again, many thanks for all your assistance and patience. Now I am eagerly awaiting my Mission Two package. This topic probably can be closed now. :wink:


#20

Larry, such great news I’m truly glad we got it all working. The missions will be sent out soon, thanks! And again, really glad we got this solved!