Rotary Angle Sensor not working[SOLVED]


#1

Recently purchased the GrovePi+ Starter kit. Not having much luck with the analog sensors.

I have connected the rotary angle sensor to analog port A2 and the green led to digital port D5. The supplied LED_fade.py program fails with “Error” being written to the screen repeatedly. I am running the script like this:

sudo python led_fade.py

I believe I a running the latest version of Raspbian for Robots (image file is 2016.05.09_Dexter_Industries_Jessie.img)

I have also tried the light sensor and sound sensor on analog ports A0 and A1. They also fail with the same symptom.


#2

Hey rsmit,
Can you run the troubleshooting script by following the instructions here https://www.youtube.com/watch?v=ZMadpIEYq5o&list=PLGXEJ4Ye1qCMWziVrynnrIPpgfOr-2aj9&index=4 and upload the log to the forums so that we can narrow down the problem .

-Karan


#3

Karan

Attached is the log.txt file


#4

Any update on this?


#5

Hey rsmith,
Sorry for taking this long to reply. Looks like the Pi is unable to communicate with the GrovePi. Can you post a picture of the setup. Did the GrovePi work a few times or has it not worked at all.

-Karan


#6

Karan

Thanks for having me re-check the setup. The GrovePi was misaligned on the Pi. All seems to be working now.

Thanks again!