Scratch, or any IDE, not Opening[SOLVED]


#1

Not sure if this belongs in the “GoPiGo” section…

We are unable to load any program via VNC that has a GUI (except Terminal and whatever you call that Python editor).

OS: Dexter Ind.’ OS that came on the microSD card (dated around Oct 2016).
Upgraded: I did perform the upgrade of the OS, to get the latest. Also performed the Dexter update for latest code.

When connected via VNC through a web browser, we get to the Raspberry Pi desktop showing all the icons. We can browse folders and files, double click on Python files and the editor for that shows up. We are able to open Terminal as well and enter commands.

But, attempting to open any other GUI-based app just “flashes the screen” and closes. ps doesn’t show it running either.

The following GUIs we are unable to open:

  • Scratch
  • any Python script with a GUI (e.g. Basic Robot Control w/Gui)

I didn’t have time to dig into the syslog for more details.

Wondering if this is a known issue and if there was a quick fix.

I also have downloaded the latest Dexter Ind. image and made another 8 GB card with it. I’ll give that a try the next time we have time to play with it.

Thank you!
Eric


#2

First thank you for providing a detailed explanation! First what vnc viewer are you using? Could you provide a screenshot of what happens when you open scratch for example? Also in the meantime try ssh. If your using Macos or Linux just type ssh -X pi@your pi’s IP address. Then type scratch If on windows install putty and find out how to enable x11 forwarding.


#3

Sorry @eduncan911dexter, it’s so frustrating when it’s not working.
Could you try the following?
Open a terminal window while in VNC
type in:
cd ~/Desktop/GoBox/Scratch_GUI

followed by
python Scratch_Start.py

and report the error that it will give you.

There are a couple of things that could trigger what you’re seeing. So I need this to know which one it is.

Cleo


#4

Hello @graykevinb. Sorry for the late reply. Just now sitting down with the kid to play with this again.

I couldn’t get -X or -Y forwarding working. Had to install Quartz, edit sshd_config, etc. A lot of stuff I didn’t want to do on this kids laptop. Farthest I got was to export DISPLAY for localhost:1.0, which got me past the auth errors and blanked the terminal with flashing cursor. I reverted all of this.

The VNC viewer I was using was whatever comes up from the http://dex.local browser options.

I actually imaged a new sd card and booted with it, which actually works now.

To recap… I was using the Dex imaged sd card dated Oct 2016. I ran apt-get update and upgrade, and then Dex Upgrade utility after that. Never could get any UI opened.

But imaging Dex’s latest image from the website, works as-is. And I did apt-get update and upgrade, along with Dex’ Upgrade later as well - and it continues to work.

Must have been a bad sd card I received.


#5

Hello @cleoqc!

This worked - on the new sd card I imaged (I didn’t try the old one). CDing to that directory, an running scratch with that command opened scratch and it is working.

To recap: clicking on the icon from the desktop just flashes a black window and disappears stills on the origin sd card that came from Dex.

I didn’t have any time to go back to the original Dex sd card to try the command. Kind of wasted too much time just to get Scratch up and going. :slight_smile:


#6

Hmmm. Odd. Does it work directly on the pi, meaning monitor hooked up? Also which vnc viewer are you using?


#7

So apparently there was a bug and I replied thinking it wasn’t working cuz I didn’t see the previous posts. Thanks @cleoqc! :slight_smile: I don’5 know as much. Glad its working!!!