Scratch


#1

I downloaded the SD image from your website last week and have successfully run the basic python scripts to control the GoPiGo. Today I am trying to use Scratch to let my kids program the robot, but when I double click the GoPiGo_Scratch_Start icon on the desktop nothing happens. I followed the links and launched the script from the terminal and got the following errors over and over again:

./GoPiGoScratch_debug.sh
Scratch is either not opened or remote sensor connections aren’t enabled
Unable to Broadcast
Scratch connection error, Retrying

Any suggestions? Thanks!


#2

Hi,
I think you have not enabled the Remote Connections in Scratch.

You should have a look at the fourth image here: http://www.dexterindustries.com/GoPiGo/learning/scratch-examples-for-the-raspberry-pi-gopigo/basic-scratch-robot/ .

Let us know if this helps.

-Karan


#3

That did the trick. I had been looking at the Scratch Programming page and it doesn’t provide that step. It might be worth adding a link. Also, after I did a chmod +x on the scripts the shortcut from the desktop is now working.

Thanks again.


#4

Great to hear that it worked out for you and sorry for the troubles.

-Karan