Seeed TFT Shield V2


#1

I am trying to use the Seeed TFT shield with my Arduberry but it only gives a blank screen with the backlight on. Are the pin assignments different for the Arduberry than the UNO? I am using the libraries from Seeed.

Steve


#2

Hi Steve,
Sorry to hear about the problem. The pin assignment for the Arduberry is exactly the same as that of the Arduino Uno and the TFT shield should have worked properly.

Have you tried it on a regular Arduino to see if it works or not. Also can you try burning the code on the Arduberry and then detaching it from the Raspberry Pi and try powering it alone to see if it works.

-Karan


#3

realizing this is an old story…BUT

I am having the same issue as above…

any news?

Could you send me a how-to link in regards to :
“burning the code on the Arduberry…”


#4

Unfortunately, I never got it to work with the Arduberry. The shield did work with an Uno.

Sorry

Steve


#5

Hey,
I just checked the specs for the TFT shield and looks like it uses all pins except Serial and I2C. So I think the problem might be from the SPI pins. Can you try this to make SPI work: http://www.dexterindustries.com/forum/?topic=spi-ethernet-enc28j60-not-quite-working/#post-2551 and let us know how it goes.

-Karan


#6

OK, really not a wizard!!
feel free to question or ask to clearify!

here goes:

checked gpio readall…everything set to IN(put) except wPI 15 and 16 ALT0.

Seems to be alright?!?
status(same)
succes uploading shield demo sketch(es), but…
still nothing but backlight.

btw setup: rasp B+, arduberry , seed shield v2.


#7

Hey,
Can you post what you see with GPIO readall. Also a few more tips: first burn the code and then change the SPI settings because the Raspberry Pi uses the SPI pins to upload the code. Also, did you press reset on the Arduberry after the code upload.

-Karan


#8

sequence :

1 connect pi b+ with arduberry with tft on top… check
2 power system… backlight on tft turns on(grey)…check
3 connect to pi and upload sketch…done uploading(pic)…check
4… nothing…back light grey…
5… check Gpio readall…no changes(pic)…check
6…reset arduberry…check
7…check gpio readall…no changes…


#9

Hey,
If the code is already on the Arduberry, and you are sure that the code is uploaded properly to the Arduberry, can you disable SPI from the raspi-config method here: http://www.raspberrypi-spy.co.uk/2014/08/enabling-the-spi-interface-on-the-raspberry-pi/ and reset the Pi and cycle power too and see if that works.

I am not sure what is going wrong and since the shield uses a lot of Pins on the Arduino, the problem could be something else too.
-Karan