Servo for GoPiGo does not rotate[SOLVED]


#1

I have installed the servo package and the Ultrasonic Sensor and the sensor run fine but the servo does not rotate the I use the canned programs in the GoPiGo Software Python area. Is there someway to see if the servo is bad or if it’s the GoPiGo board? The only troubleshooting device I have is a voltmeter.


#2

Hey skismx5,
Can you run the basic_test_all.py example here: https://github.com/DexterInd/GoPiGo/blob/master/Software/Python/basic_test_all.py and give it a f,v command to get the firmware version and the voltage. After that can you try a servo sweep command by entering b and then individually check servo positions with the st command and then entering the angles between 0-180. It would be great if you could upload a video too of what the servo is doing right now and can you double-check that the servo is connected the Right way with the GoPiGo from the video here: https://www.youtube.com/watch?v=mmmD64sKxPg.

Do let us know if this works for you.

-Karan


#3

Thanks you for your help. I have added 4 pictures and a short video. The FW version is 1.6 and the voltage test is 101.97.

I get no response from the ‘b’ or ‘st’ tests as you may see in the video link on you tube is https://youtu.be/2_ac1t3PAcU I’ll see if I can up load it her.

I’m also uploading three pictures of the connection of the servo. Two side views and one top view.

The servo never moves from a command line bit O do see some blue LED flash whenI run the b command.

What can I check next?


#4

It looks like the servo connector is connected the wrong way. Can you try invert the connector when it’s connected to the GoPiGo (Yellow towards the left LED).

Do let us know if this helps.

-Karan


#5

Karan,

That was the issue but I’m so confused. The video stated the yellow should be on the right side but now is on the left side. So maybe at 71 I’m just confused but it isa now working so thank you.

I would have reversed the cable myself but not knowing if that might cause harm I didn’t try it until you suggested it.

Thanks again for your help.

Ski


#6

Hey Ski,
Great to hear that it worked for you. The video was for the older GoPiGo. We have just moved on to the newer version of the GoPiGo which has the connections inverted. We’ll be updating the instructions and the videos asap.

-Karan


#7

Hi Karan & John,

As of Oct. 2016, the video of installing Servo for GoPiGo2 is still the old GoPiGo one. I bought GoPiGo2 a couple of weeks ago and encountered the same issue, Servo was not rotating. Spent time checking out this Forum and found the answer is “inverting the connector” :frowning:

But don’t get discouraged by this issue. Overall you guys did an excellent job. Delivered so many cool products with so limited resources. Great Job!


#8

The written instructions are already up to date.
I haven’t checked if there are two videos yet. Thanks for bringing it to our attention.