Servo mount doesn't work[SOLVED]


#1

Hello,
I recently got a GoPiGo starter kit and successfully assembled and tested the robot but when it came to the additional servo motor there were problems getting it mounted properly. I made a little demo video showing that 1) the servo-mount connection is loose and 2) the mount doesn’t stay on the body with the screws provided. I can try using larger screws but don’t know how to make the connection to the motor tighter. I wrote to see if I could get a new mounting piece but was just told to write a forum query :frowning:


#2

The screws go through the acrylic base first and then into servo arm. It looks like you have it the other way around.


#3

Hey,
Sorry for the troubles that you had to face with the servo. Have you followed the video here: https://www.youtube.com/watch?v=SRQ1p-Gu_-0 and here: https://www.youtube.com/watch?v=mmmD64sKxPg to connect the Servo to the GoPiGo. Can you also upload some good pictures of the servo arm connection.

-Karan


#4

Hello Sberry, I think the two above comments are correct: it looks like the servo was mounted a bit out of order. The two videos that Karan posted are great, and the written tutorial here: http://www.dexterindustries.com/GoPiGo/getting-started-with-your-gopigo-raspberry-pi-robot-kit-2/1-assemble-the-gopigo-2/assemble-servo-package-assemble-the-raspberry-pi-robot-servo-kit-with-the-gopigo/

In particular, these two pictures might be helpful:

If that doesn’t help, can you post a picture of how you have the servo mounted to the GoPiGo?


#5

Yes, thank you everyone! I tried to attach it on top instead of from below the body.