Setting up the Arduberry


#1

I was having a trouble with this guide, so I spent a little time working on it. I tried to run this script: “cd Arduberry/script”, but it kept saying “No such file or directory”. Next I opened the file manager and found the folder. After that I opened it and added “script” to the end of “/home/pi/arduberry/”. Then I typed this in terminal “cd /home/pi/arduberry/scripts”.

In the end it worked fine. I also noticed that the link to the “blink led” was broken.

Akunicycler


#2

Hey Akunicycler,
Thanks for the tip! We really appreciate the feedback; any other trouble you have please let us know. We’ll make the changes pronto.


#3

I found a great tutorial on making an led blink on youtube. After writing the script go to tools, then click upload using programmer, or control+shift+u. (note only do this step if you don’t have a separate power supply for your Arduberry)Then shutdown the raspberry pi and pull apart the arduberry from it (I am not sure if pulling it apart is necessary). Plug in the arduberry and put the longer led lead into ground and the shorter into port thirteen. I may have gotten which way it goes mixed up, but everything else should be correct.


#4

I ran the install without errors. Cloned files look OK. when I get to the Arduino IDE step, the entry is not in my desktops list of commands. Folder isn’t there. I looked for it via command line. Looks like it was not installed during setup. Am I misunderstanding the guide? I thought it was installed by the script.

Followup: I’ve installed the IDE manually and all is working. Useful instructions at: http://razzpisampler.oreilly.com/ch10.html


#5

Hi nexuswest,
So the script did not work for you right? I’ll test out the script once to see if there’s any problem.


#6

Correct, the script didn’t install the IDE. Having installed it manually, though, I am encountering other issues. See thread re “cannot find COM1”. I do not seem to have the necessary configuration options available on my installation. As I am a first time user of this product, and am discovering other gaps in the tutorial pages from reading that thread, I am unsure whether the missing config items are caused by the way I installed or other cause.


#7

I re-ran the install script and picked up multiple updates. I still do not have the ability to select serial port in the Tools menu, but I now have Raspberry Pi GPIO as an option under Programmer.


#8

Upload succeeded this time, but nothing happens after I get the done message. Need to read further. I suspect I’m seeing the issue of no led on pin 13 per the COM1 thread? Off to do more research.


#9

We solved the Serial port visibility issue just recently and is included in the latest Image. We have not added it to the install script yet.

The serial port is /dev/ttyAMA0 and does not appear in the Arduino IDE. You can use : ln -sf /dev/ttyAMA0 /dev/ttyS0 to make it appear in the Serial Port Menu and you’ll have to add it to crontab in crontab -e to make it load up on boot.

Please let us know if you face any other problems.

-Karan


#10

When your update is added to the install script, will it use the same crontab fix, or is it a permanent fix (i.e. should I plan to reinstall once that update is released)?


#11

The script update will be the same as the crontab fix. You should go ahead and use it.


#12

Thanks Karan. I implemented it last night and the serial port now is un-greyed and selectable.