[SOLVED] AVR device not responding (Motors not working)

troubleshoot
avr
bug
gopigo

#1

Hi,

I’ve run the test and troubleshoot files and do not get any response from the motors. I have attached the log file that is generated from that test. I believe it has something to do with the “avr device not responding”. I’ve checked the connections and they seem to be working fine. I’m using raspbian for robots.

log.txt (6.1 KB)

Thanks,
Aaron


#2

Hi @aflaaen,

Can you show us how is your GoPiGo connected to your Raspberry Pi?


When we see the AVR device not responding error, we think of 3 possible scenarios:

  1. There’s a bad connection between the Raspberry Pi and the GoPiGo board - this means the board wasn’t plugged in correctly.

  2. There’s something that’s preventing the SPI pins from working correctly - probably the foam wasn’t removed when the robot was unpacked.

  3. There’s a cold solder joint on the board.

That’s why we first want to see a couple of close-up pictures of your setup/assembly. We really appreciate seeing high-res pictures, as these can help us better understand the situation.


Also, before replying us, could you try updating the firmware of the GoPiGo again - just to be sure that it doesn’t work?
Here’s a screenshot that shows the steps that need to be followed in order to update the GoPiGo's firmware.


Let’s hope we get to solve your issue as fast as possible.

Thank you!


#3

Thanks for the help. I did the software update and tried the tests again with the same result. I will go ahead and check the connections ot see if there is anything that is inhibiting the connection between the Pi and the GoPiGo board. I have attached some pictures if you can diagnose the issue, though I admit it might be hard to see things clearly. I will respond again if I can resolve the issue by re-assembly.


Thanks again!


#4


#5


#6

Hi @aflaaen,


It seems like your using a GoPiGo3 and not a GoPiGo.

It also seems like your GoPiGo3 didn’t come with a firmware on it and because of this, the RaspberryPi is unable to detect the robot and hence, it’s not possible troubleshoot it properly.


We now want to update the GoPiGo3 (instead of updating the GoPiGo, which of course, shouldn’t have worked) and then check the hardware.

Here’s how we do it (you need to open up a terminal on your RaspberryPi):

  1. cd /home/pi/Dexter/GoPiGo3/Firmware

  2. sudo bash gopigo3_flash_firmware.sh - and show us the output of this script.

  3. cd /home/pi/Dexter/GoPiGo3/Troubleshooting/

  4. sudo bash all_tests.sh

  5. And then copy the log.txt file that’s available on the desktop and put it here.


Thank you!


#7

Thanks for the help. Yes, it looks like there are some GoPiGo vs GoPiGo3 issues (the GoPiGo3 was launched days after I placed my order, and so I ended up getting the GoPiGo3 without knowing it.) My directory does not have a GoPiGo3 folder (see attached screenshot) – only a GoPiGo folder – and so I can’t perform the steps (GoPiGo3 specific) you’ve requested. What to do? Do I need a fresh download of Raspbian? Thanks again,


#8

Hi @aflaaen,

It seems like you have an older version of Raspbian For Robots.

There are 2 ways on getting it updated:

  1. Time-consuming option: Update Raspbian For Robots through DI Software Update icon that’s on the Pi’s desktop. After you load the interface, press on Update Dexter Software.

  2. Fast option: just enter the following command in your terminal and after a few minutes, your GoPiGo3 dependencies should be updated to the latest:
    sudo curl https://raw.githubusercontent.com/DexterInd/Raspbian_For_Robots/master/upd_script/fetch_gopigo3.sh | bash

By now, you should have your GoPiGo3 dependencies updated.
Redo all the steps I’ve given you in my anterior post and it should work.

Please, keep me updated.

Thank you!


#9

Thanks for the help. Option 2 did not work (I didn’t remember to get a screenshot of what the issue was ), but option 1 worked and now I have full control over the motors. I think I’m all set. Thanks again!

-Aaron


#10

Hi @aflaaen,

I’m happy to hear it worked out for you.

I’m still wondering why it didn’t work the first option for you - I’ve just tested it on my Raspberry Pi and the update went fine.
If you get the chance again to run the command, could you share with us a screenshot?

Thank you!