[solved] Browser_Streaming_Robot Not Working


#1

Hello,

I am trying to utilize the Browser functionality and it is not working. I have enabled the Camera and follow the instructions here:


and the Dexter’s instruction

Attached is a screenshot of my Chrome browser and the terminal stack trace from my attempts to run the program.

Urgent assistance would be appropriated!

Best,
Jeremy

error.txt (4.1 KB)


#2

Hi @jeremy.grace01,

Thanks for bringing this to our notice, this seems a like a new bug, we will work on it and get back to you shortly.

-Shoban


#3

Hi @jeremy.grace01,

Can you try running the following commands step by step on the terminal and then see if the example works

sudo git clone https://bitbucket.org/DexterIndustries/raspberry_pi_camera_streamer.git
cd raspberry_pi_camera_streamer
sudo mkdir build
cd build
sudo cmake ../
sudo make
sudo make install
cd ../../

sudo rm -R raspberry_pi_camera_streamer

-Shoban


#4

Hi @Shoban, I will definitely do that soon and let you know how it goes! I don’t know if this might be connected to the issue (I guess we will see), but I’m no longer able to utilize RealVNC to access the GUI for the operation system. I just keep getting a “The connection was refused by the computer” error message. Any ideas? Thankfully, SSH still appears to be working fine.

Jeremy


#5

Hi @Shoban,

I ran the script you provided and IT WORKS! Thank you!

The joystick appears to be reversed on LEFT and RIGHT directions (i.e. I move the joystick RIGHT and it moves/displays LEFT, etc.) Maybe that’s typical since this is the first time I am getting it to work.

The RealVNC is still not functioning. I wonder if it could be a Wifi IP address issue. But the SSH is still working, so I don’t know.

Thanks again!
J


#6

Hi @jeremy.grace01,

Glad that it works for you. Try reversing the order in which you have connected the motor pins to the GoPiGo board and it also depends on which side of the GoPiGo is front and rear for you. Regarding to have the Realvnc to work, are you working with the Ethernet connected to Laptop, if so try disconnecting it and try again.

Also try clearing your cache in the browser and open the browser in an incognito or private viewing mode and try accessing the noVNC on the browser again.

Please let us know if this helps,
-Shoban


#7

Hi @Shoban,

Thanks for the prompt response! I actually I’ve not been using the Ethernet connection since I initially setup the interface (which has been working until now). I cleared the browser cache and tried noVNC in an incognito window to no avail! Attached is my troubleshoot/test log file for reference on how I might proceed.

Thanks again,
Jeremy

log.txt (7.4 KB)

Screenshot of connection in a regular browser window (incognito window was the same).


#8

Hi @jeremy.grace01,

I meant if you were using Raspbian for Robots image , then type dex.local on your browsers’ address bar and it will take you to a page where you can use noVNC. You can follow the instructions given in this page to get connected.

Please let us know if this helps,
-Shoban


#9

Try the way provided by Raspbian for Robots. You just​ go to http://dex.local
Raspbian for Robots automatically creates that page on bootup. That should work, if that page doesn’t come up try another browser.


#10

Hi @Shoban and @graykevinb,

Attached is a short video or how my attempts to open a browser connection have failed. As you can see, I have a reliable SSH connection (I can even ping the internets and either device on the other with success.) and the command appears to not be working for me.

Please let me know how I might proceed from here.

Thanks,
Jeremy


#11

File too large. please access it from here:

Plus, here is a picture of the response when trying to use the VNC client like I was originally doing (this was working for me up until this past week):


#12

Hi @Shoban and @graykevinb,

I figured out what was wrong and am able to access the Remote Desktop/VNC now! Apparently, my VNC dependencies got removed (so I installed them) and the VNC setup via sudo raspi-config was disabled?! Very strange. So I Enabled it and the appropriate dependencies were installed.

I went ahead and ran another troubleshoot/test script for your reference. It is attached below. I will let you know if anything negatively changes.

What could’ve removed these files and Disabled the VNC connection? A reboot or update?

Thanks again for all of your help,
Jeremy

log.txt (6.7 KB)


#13

Hi @jeremy.grace01,


I’m glad you have it working now. That’s great to hear.

I think the recent updates for the Raspbian might have disabled the VNC, hence the reason it didn’t work for you in the beginning.


Thank you


#14

Hi @RobertLucian,

I was thinking it might be something like that since I am diligent about sudo apt-get update ing at least every other time I SSH into the Pi. I will keep this in mind for the future.

Thanks again,
Jeremy


#15

Also keep in mind SD cards seem to have a mind of their own and corrupt themselves. Meaning files, like vnc files, could go poof.


#16

This topic was automatically closed after 24 hours. New replies are no longer allowed.