[Solved] Cannot connect to gopigo3 using wifi

Hi everyone,

I installed Raspbian for robots on Gopigo3. I connected to the robot using Ethernet cable (http://dex.local then VNC icon) then connect the robot to the home wifi and made all the updates and upgrades. However, when I disconnected the cable and tried http://dex.local it does not work. I also tried using the wifi of the my phone but does not work. Can anyone help? Thank you

Hello @Amraba

When you are connected via Ethernet and you can connect via VNC, please open a terminal window and type

Look at the line that says wlan0, and find the IP address as per this image:

You should be able to connect to your robot using the IP instead. for this image.

it seems your home network does not allow for discovery by name on the wifi network.

Hi @cleoqc,
Thank you very much for your response. I spent all the day trying to connect, finally I just find the problem : it was my Kaspersky that blocks the connection… :slight_smile:
Thanks again

1 Like

Great! Good to know about Kaspersky. Thanks for letting us know.