[SOLVED] Cannot connect to GPG3 with https://10.10.10.10

dexteros
#1

DexterOS 2.3.0 get green light. have GoPiGo WiFi . https://10.10.10.10 get “Safari cannot connect to Server” . Green light turns blue. Tried other Raspberry Pi get "This site cannot be reached.

Terminal ifconfig . get inet 10.10.10.11 netmask 255.255.255.0 broadcast 10.10.10.255

ping 10.10.10.10 worked (from other)Raspberry pi. Also works from terminal on iMac (MacOS 10.14.4) . Tried Opera Browser on iMac https://10.10.10.10 and "this site

I CAN’T BELIEVE IT WORKS OK with http://10.10.10.10 . removing the “s” did it.

Any idea why?

Thx,

Carl

1 Like
#2

https protocol requires a special encryption agreement between the browser and the server called a certificate. Since you don’t have a certificate setup, you can only use the unencrypted http protocol.

#3

Thx. Makes sense. But, I get into other https sites all the time. Also, a month ago (been busy on other projects) the https worked. GoPiGo3 has just been sitting there. When it didn’t work I redid the microSD card. Still failed & just tried the http (without the “s”) as a lark. I also though that if someone says use https that the http would not work. Guess I have to learn more about the whole certificate thing.

Thx again.

C

1 Like