[Solved] Can't get my first Test to run


#1

Hi all-
My son and I just got a basic GoPiGo and are stuck. We build it (easy), hooked it up to the computer (a Mac, easy), did the WiFi set-up (a little more challenging - it took several tries for the GoPi to hang onto my home WiFi and get an IP address, then it kept dropping it - or being dropped - so it took several tries to successfully disconnect the ethernet cable, but we finally got it!)

Now we’re stuck running the first basic test. When we go to the GoPi’s desktop and click the “Test and Troubleshoot” icon, the little black terminal pops up for like 2 seconds, and then winks out. It’s not behind the main browser window or hidden anywhere else; it’s just shutting itself off instantly. I’ve tried opening it 20 times and it won’t stay open (and it’s so quick that I can’t even tell if there is an error message).

So we’re not even getting to point where some window asks us if we want to run a test.

We’ve looked i the other folders on the GoPi but can’t find anything that looks like an alternative way to run the test, so we’re just kinda’ stuck. Help.

BTW - According to the little “Version” icon, we’re running GoPi software version 6.6. And on the Mac we’re running 10.11.1 and Firefox 42.0.

Any help would be appreciated.

Thanks.


#2

Can you try pulling the program up in the terminal. If you open LXTerminal and type:

sudo python /home/pi/Desktop/GoBox/Troubleshooting_GUI/troubleshoot.py

It should either work, or throw an error message. If it doesn’t work, what error does it throw?

John


#3

I get “no such file or directory”


#4

BrianGuerrero,

The files might have been deleted. I’m attaching a quick screenshot of my just doing it on a fresh image. Attached is the picture of it running.

If that doesn’t work, let’s try updating the software. Can you try the steps in this video:

to update the software. If the files are missing, this should download the latest version and install them.

Is it possible to include a screenshot of your desktop?


#5

Just to be clear, I think you only need to run the “Update the Dexter Industries Software” option. Click that button, and run the update to completion. If you see any errors rolling by in the terminal, can you note them for us?


#6

Ok, ran the “DI Software Update” icon, then restarted the robot.

Tried to open the “Test and Troubleshoot” icon, but it did the same thing - it opens for like 2 seconds then self-shuts-down.

I opened the “LXTerminal” icon again and ran the sudo python line [actually, I may have been entering it wrong before; I wasn’t putting a space between “python” and “/home”]. However, it still didn’t work. Here is a screen shot of the error message from the terminal + what my desktop looks like:

Thanks for the help!
Brian


#7

Hey Brian,

Great, we’re getting somewhere, I think I have an idea about what might have happened.

I think to fix it all you’ll need to do is run this in lx terminal:
sudo apt-get install python-wxgtk2.8 python-wxtools wx2.8-i18n --force-yes

If you run that command (make sure you’re connected to the internet first), and then either re-run the command

sudo python /home/pi/Desktop/GoBox/Troubleshooting_GUI/troubleshoot.py

or try the desktop icon, it should work.

The long story is there’s a support software package that runs in the background called wx. You can see that somehow that got removed and didn’t get reinstalled. This probably happened when an update was interrupted.

Please let me know the result!


#8

Boom! That did the trick! Thank you so much. Looking forward to our second mission and learning to program.

Much appreciation,
Brian Guerrero


#9

Best news of the day, I’m glad we were able to work through this!