[SOLVED] Can't make grovepi work

grovepi
#1

Hi,
I made an SD card with dexterOS, and I pluged everything correctly. the os work correctly. when I try to use python, everything is fine. when I try to import grovepi, no problem. But when I try to read the sensors, nothing appears. I have a digital light sensor, and a temperature sensor.
Any idea of what I made wrong ?
Any detailled tutorial to suggest me ?
Thanks for your help.
Jérôme

#2

DexterOS wasn’t made to work with the GrovePi. For that, you need to switch to Raspbian for Robots or at least a fresh version of Raspbian. You’ll have to update the libraries and the GrovePi’s firmware (most likely).

Here’s a getting started guide on that:
https://dexterind.github.io/GrovePi/quickstart/

Thank you!

#3

Yes, I known, sorry, I have raspbian for robots. the latest version. When I write from grovepi import in python, the instruction is accepted, so the module is known. but when i use it to read from a sensor, the program works but nothing is writen in the shell.
thank you

#4

Have you tried updating the firmware? Here’s how you can do it:
https://dexterind.github.io/GrovePi/fw/#flashing-the-firmware

Can you try that, as I can remember this being the behavior of when a newer library is used with an old version of the firmware?

Thank you!

#6

Thank you, it works.

#7

That’s really great. Thank you. And I’m going to mark as solved this thread and lock it.

closed #8