[SOLVED] Can't ping dex.local Mac (Sierra 10.12.5)


#1

I am having an issue connecting my GoPiGo robot to dex.local on my Mac. I went to VNC viewer and typed in the IP that I have assigned and the computer refuses the connection. I can ping the IP no problem but when trying to ping dex.local I get the following error: “ping: cannot resolve dex.local: Unknown host”. I have tried all the suggestions already listed in the Help forum for this topic and have had no success. Any further advice or suggestions.

Thank you in advance!


#2

Are you using Raspbian for robots? If not it won’t work. If you already have files for Dexter Industries robots Such as the GiPiGo folder than your using Raspbian for robots.


#3

Hi graykevinb, thank you for responding.

Here are the steps that I have completed without any luck:

  1. I went to https://sourceforge.net/projects/dexterindustriesraspbianflavor/ and downloaded the rar file, extracted it, and installed it on my micro SD card.
  2. I connected my robot to my Airport base on my Mac via ethernet.
  3. In the terminal I pinged dex.local and received the following message “ping: cannot resolve dex.local: Unknown host”
  4. Typing http://dex.local in a browser yields the same results.

I cannot get anything to connect. Any thoughts?

Thank you!


#4

I’m going to suggest a few things but I am not a Mac specialist. (I can hear @JohnC laugh at this already… )

  1. Are you able to get IP addresses for everything that’s physically connected to your Airport base? Is there a control panel that you can go to that will provide you with this information? If so try pinging the one that would be the GoPiGo.
  2. You say you connected via Ethernet to your “Airport Base on your Mac”. Do you mean the actual Airport Base, or simply the Ethernet port on your mac?
  3. What is the status of the LEDs on the Pi. Are you confident you have a good boot?

Cleo


#5

I also would like to add that you could try it with your GiPiGo connected to your WiFi instead of your Airport Base.
Perhaps the Airport Base causes issues with it.


#6

Is VNC enabled on the RPi???


#7

This may sound like a silly question, but how do you check if VNC is enabled?


#8

I want to add I’m using a 32G PKY micro SD card. On my Mac it’s only allowing me read access so I have to burn the image to the card using my Windows laptop. I don’t know that is causing issues or not. I can’t seem to unlock the card on my Mac.


#9

UPDATE: I got things working! I downloaded the updated version of Raspbian for Robots and loaded it on my micro SD card using my Windows laptop. Put the SD card into my robot and booted it up, connected to Wifi, launched the browser and went to http://dex.local and bam! Went to my Mac browser and typed in http://dex.local and it instantly connected using VNC. Woo hoo!

Thank you to everyone for the suggestions, they all helped in solving my issue! ::relaxed:


#10

Yeah!!!
I’m assuming the burn on the MAC didn’t succeed for some reason, and you ended up with a non booting Pi.
What software were you using? (on both of them?)
Cleo


#11

@Shane.gingell
To answer your question,
VNC is enabled by default on Raspbian for Robots. Not on the vanilla version of Raspbian.


#12

On all my RPi running the standard Raspain for robots Jessie they all install with VNC and SHH turned off. Supposedly in the latest versions this was done for security purposes. To start first boot headless you have to add a file to the boot directory to turn SHH on. Picam, IC2, and 1 wire are also turned off by default on the latest versions that I downloaded.


#13

It was even more confusing for head;less first boot up on my RPi Zero W as it doesn’t have n ethernet port so can only connect over WiFi so you have to edit the config.txt file in the boot directory to add your WiFi router and password.


#14

And that’s why Raspbian for Robots exists :+1:
All those settings and more are already set up, and it contains all the Dexter software.
It’s meant to work out of the box


#15

cleoqc,

I tried the burn on my Mac but because the card only allowed me read access, I used my Windows laptop for the burn. I downloaded the image on my Mac, saved it to a USB, and then just transferred copied the image to my laptop. I used Etcher (https://etcher.io/) for the burn, super easy.

I think one of the issues from the start as graykevinb pointed out, was that I didn’t download Raspbian for Robots and downloaded Raspbian Jessie with Pixel instead. Raspbian for Robots had everything I needed and it was smooth sailing from there. :slight_smile:


#16