[SOLVED] Can't run scripts with GrovePi

grovepi

#1

I have installed software for GrovePi and have tried bundled programs for various Grove sensors, but all come back with errors when I try to run them (Python programs) I ran the troubleshooting program and have attached the log file. Any help would be greatly appreciated.log.txt (6.6 KB)


#2

Hi @jlafavre,

Could you burn the firmware onto the GrovePi?

The script you have to run in order to update your GrovePi is:

Please let me know if this was your issue.

Cheers!


#3

Thanks for your help. Initially I did not burn firmware to the GrovePi. I was following instructions from here: www.dexterindustries.com/GrovePi/get-started-with-the-grovepi/setting-software/ and those instructions did not include steps to burn the firmware that I noticed. In any case, I copied the firmware_update.sh script to a directory I made on the pi (/home/pi/LaFavre_Grove/GrovePi) and made it executable but could not get it to run. Then I discovered there already was the same file located here: /home/pi/Desktop/GrovePi/Firmware/firmware_update.sh
I ran that copy of the script and it appeared to install the firmware. Now I can get my Grove sensors to work with the GrovePi. Thanks very much for your help


#4

Hi @jlafavre,

I’m glad to hear it worked for you.
I’m going to close the thread if there isn’t anything else.

Cheers!


#5

This topic was automatically closed after 18 hours. New replies are no longer allowed.