[SOLVED] DexterOS "No robot connected"

dexteros

#1

Please excuse me if this question has been answered before. I have searched this forum and used Google to find solutions but I cannot find an exactly similar question.

I am new to using Pi’s and robotica. I have no knowledge about Raspbian for robots or other platforms/uses. Please bear with me :wink:

My setup:
Windows 10 laptop / Android 8 Oneplus 3T
Gopigo3
DexterOS 1.0.1 2017.06.15 SD card
USB stick 16 GB (new) with latest DexterOS (downloaded March 28, 2018)

My problem:
I have followed all beginner tutorials to assamble the robot, run the usbstick update and connect it to my devices.

First I tried my phone, it connects to the Gopigo - I could see the blue led.
But when i go to http://mygopigo.com it says that there is no robot connected.

Then I tried my laptop, and I have exactly the same problem.

I have seen people with connection problems using the advanced set up (Raspbian for robots, etc) that have to do with the kind of wifi they use (2,4 or 5 Ghz). I know my router is set for 5 Ghz, could this be the problem?

I would be very grateful if someone could help me out, keeping in mind that I have no Linux or Raspberry command knowledge what so ever.


#2

Hello @TalentThat,

so far, you’re doing great! You manage to do quite a lot for someone who claims to be totally new. Plus you’ve given us exactly the information we need to help you. Very much appreciated.

You say you ran the update file on the usbstick. Did you notice the two blinkers (the red lights at the front of the robot) blink ? That will indicate the update is running. Also, once you pulled the USB out, is the DexterOS_update file gone from it?

You started with DexterOS 1.01 That specific version requires the update to be run TWICE in order to work properly. So if you ran it once, you will have to do it again. Apologies for that. It’s a pain, and I’m sorry. The good news is that only that version needs a double update.

Once you’ve run the update twice, you should be able to connect. If for some reason mygopigo.com is not recognised, try 10.10.10.10

And please let us know how it goes!
Cleo


#3

Thanks for your kind words :slight_smile:

I ran the update again and…it works!!


#4

Yeah! And thanks for letting us know the outcome!

Cleo


#5

This topic was automatically closed after 24 hours. New replies are no longer allowed.