[Solved] Electrical board doesn't turn on or connect to Pi


#1

Hi,

My red electrical board (REB), V16.9, won’t turn on with just the battery pack attached. And I know the batteries are fine because I’ve tested them to make sure they have full power and they do. I only get power on the REB when the Pi (B+ V1.2) is connected to it and the micro usb slot on the Pi is providing power; however, in this case, the Pi won’t turn on. And the Pi works perfectly fine when not connected to the electrical board. Help?! I’m using this for an individual project in my Masters class and can’t do anything with the rover if I can’t connect to the electrical board.

Thanks,
Jason


#2

Hi @jasonkokotailo,

Can you send us a few screenshots of the board with micro USB power supply and Battery supply connected to GoPiGo. Also can you double check if the power switch is turned ON, like in the image below.

You had also mentioned that the Pi won’t turn ON when connected to GoPiGo board and when powered through micro usb slot, can you elaborate a little more about this. Like are you able to see the PWR led on the Pi turn ON and also if the PWR led on the Pi is not turned ON, are you still able to access the Pi.

-Shoban


#3

Hi Shoban,

It magically seems to be working now. I removed everything into their separate parts including the electrical board from the motors, then the electrical board started turning on with the battery pack and when I put everything back together, everything still worked. Magic :slight_smile:

Thank you very much for your prompt reply! If I experience any other difficulties, I will let you know.

Sincerely,
Jason


#4