[SOLVED]Error received while updating Raspbian for Robots


#1

I ran the update script from the VNC desktop and received the error screen in terminal, see attached file. The screen appeared to lock up and I could not select an option or select OK. Now my VNC desktop is hosed but I can connect via terminal.

How do I update Raspbian For Robots from terminal?

-Sparx


#2

I received that same error while updating using vnc. It also corrupted my microSD card. Couldn’t reboot it. I hadn’t made a backup so had to download a new image and re-burn the microSD card. Better luck to you!


#3

Yup. Tried to update via ssh terminal but my host is unresolvable because I cannot connect to the pi via http://dex.local.

Hosed

Burned image again and will go back through the setup process to get my wifi config back.

How do you backup the pi image after you config? It would be nice to not have to re-invent the wheel, so to speak, after the SD is corrupted.

My daughter is rapidly loosing interest in her GoPiGo. This is maybe too intense for a noob to continue to see software and firmware issues and still maintain much enthusiasm for the little GoPi to Go.

-Sparx


#4

So what is the correct selection from the list of possibilities for the Samba update???

-Sparx


#5

Hey Sparx, I think this may be another issue on our end; a mistake I made and discovered (and I thought recently corrected) in the operating system files. Can you help me a little so I can troubleshoot it? What version of Raspbian for Robots were you starting with that you saw this error? Was it 2015.11.0x or 2016.01.0x?


#6

I was updating from Raspbian for Robots 2015.11.09.


#7

Hey Sparx, we’ve since fixed the problem. We might need to re-image the sd card with the latest update; before we do that let’s try running:

sudo sh /home/pi/update_backup.sh

Can you try running that, then running the software update again?


#8

Thanks John

Pi is now running RfR version 2016_01_04 and it looks like the GPG firmware version is 1.6


#9

So did this fix the problem? Were you able to run the script then run the update?


#10

Yes


#11

GREAT!