[SOLVED] Etcher says SD card is locked


#1

I attached an image below to show what Etcher says when I try to burn the Raspian image to it. If the SD card was write protected, I tried to change that by using the command prompt and typing the commands “diskpart,” “list disk,” “select disk 1,” and “attributes disk clear read only,” but Etcher still says the SD card is locked.


#2

Usually SD cards are physically locked. Take a look at this image. To unlock the SD card, the little whatchamacallit should be slid to the top. Is that your case?


#3

Yes, that was the case. I unlocked it, and I burned the image to it. But
now, when I plug the SD card into the Rasberry Pi and then connect it to a
power source, only the red light lights up. No green light. Previously,
before I burnt the image to it, The red light would come on and the green
light would blink sporadically, which is what was supposed to happen. Now
the green light doesn’t come on at all.


#4

@wolfenstein11x,
If the red light is on, it indicates a problem with the SD card. It looks like the image did not burn properly or might have been corrupted or the SD card is not inserted properly.

If the SD card is properly inserted, can you burn the SD card again with a fresh image rather than the older image and see if that works.


#5

Are you sure the red light indicates a problem with the SD card? Because in
the video where it shows how to power it up, it says the red light is
supposed to be on and the green light is supposed to be blinking.


#6

I think @karan just skipped a step there. The red light indicate power is on. If the red light is on (there’s power) and the green light isn’t on, then it’s a problem with the SD card.
Sorry about that. Yes the red light is supposed to be on and so is the green light (blinking)


#7

I replaced the SD card, and the green light is now blinking like it should. However, when I connect the BrickPi to the TV with the HDMI cable, nothing happens. The HDMI cable and TV both work, I tried connecting my laptop to the TV and the laptop screen popped up almost immediately. I don’t know what is wrong, but what I really want is to be able to boot up the BrickPi and program it from my laptop. I tried to find some videos on how to do that, but could not quite follow them. Do you know where I can find good instructions on how to do that? Also, note that I don’t have wireless internet in my house. The videos I did find on the subject I think all worked on the assumption of a wireless internet connection.


#8

Hello @wolfenstein11x

Two things:
for the HDMI port to work, your Pi has to be connected to the screen before the boot. That’s the way Pis work. Could it be that you plugged it into the TV after it booted?

You can connect to your BrickPi via the laptop with an ethernet cable and not just wifi. Wifi is usually the preferred method as you would be able to keep the connection going while the robot moves all over the place. However not all robots roam about so it could very well be that an Ethernet cable is fine with you.
You can refer to this page to help you with Ethernet setup


#9

I was able to connect the BrickPi to the laptop with an Ethernet cable after reading this message two weeks ago, however I tried again today and could not. I can’t remember how I did it the first time. I followed the instructions from the link you gave me, but nothing happens this time. I plugged in the Ethernet cable, then powered it up. Everything lit up as it should. But then nothing came up on the laptop. I don’t know if I have to something, or if it is supposed to come up automatically.


#10

welcome back @wolfenstein11x

I’m not entirely sure where you’re standing right now.
Did you start a browser and type in http://dex.local ?
Is that responding? Are you seeing something at this point?


#11

I tried typing http://dex.local in the internet explorer browser but
nothing happened. (I don’t have any wireless internet). So the point I am
at is that there is no response to opening a browser and typing anything
in. I feel like I remember the Raspian coming up automatically when I
connected the BrickPi with the Ethernet cable before, but maybe I’m not
remembering correctly. If I’m not remembering correctly, then there is some
step or set of steps I’m forgetting to do after you connect the Ethernet
cable from the laptop to the BrickPi and power it up.


#12

Sorry for the delay here. Christmas and all.

So nothing at all comes up when you type dex.local in your browser? No error message, nothing?

Are you able to ping the robot? To test this, you might want to open up a terminal window on your laptop (for Windows, start a command prompt) and type in
ping dex.local

Cleo


#13

I got it to work. Now, I need help programming it. I just want to start out
with the basics and work my way up, but I’m having a hard time finding
anything basic. I know basic python, I’ve done those tutorials on
codecademy etc., made a prime number calculator, a "guess the number game"
etc., but I don’t know how to get started with the BrickPi. For now, I just
want to know the commands to make a motor run. Also, I need to know how to
install the BrickPi module. I’m not entirely sure if I followed the
instructions correctly. I attached the instructions I’m talking about.


#14

Hi @wolfenstein11x,

The installation steps you have posted here, are for users using images other than our Raspbian for Robots Image. From the above posts it looks like you have installed our image on your SD card and you are able to use them. In our image, BrickPi libraries come installed and you can directly get started with it.

You will have to navigate using cd /home/pi/Desktop/BrickPi_Python/Sensor_Examples/ command on your terminal, where you can find our example LEGO-Motor_Test.py. This example shows how to run your Motors. To run this example use sudo python LEGO-Motor_Test.py. You can also find this example in our Github repository here.

Please let us know if this helps,
-Shoban


#15