[Solved] Getting started, not much happens

pibplus
dexteros
gopigo3

#1

Here’s my setup:
GoPiGo3 Basic Kit
Dexter WiFi dongle
Sandisk USB Flash drive
Raspberry Pi B+
Canakit power supply
Downloaded DexterOS (SAM-1.0.1_Final.zip)

When I power the RPi with a regular microUSB power supply (5v, 2.0A), only the power light comes on (always red). I can connect via the WiFi as expected on 10.10.10.10, but the antenna LED never comes on (I can see the dongle light flickering and activity on the Flash drive).

Trying Bloxter, none of the LED, eyes or blinkers blocks do anything. Trying the Python examples, I get an error stating it expects firmware 0.2.x, current firmware is 0.3.1

So, is this all expected? Do the GoPiGo3 board lights only work when on battery power? What about the firmware error? Also, did the OS auto expand to the entire SD card? Usually I do that step, but the new Pixel OS takes care of that and reboots automatically on the first startup. Lastly, what’s the default passwd for the pi account? Neither raspberry or robots1234 worked.

Thanks and sorry for so many questions!


#2

Followup - I powered up the GPG3 on batteries, the power LED does now show green. Still nothing when I try the Bloxter programming to blink the “eyes” or the LED mounted on the edge of the GoPiGo3 board. Is this because I’m using a Raspberry Pi B+? Or is this the firmware issue seen when trying to run a Python example?

I’ve built all my GPGs with the B+ since I had a lot of them on-hand. Otherwise, I’m not planning on using a RPi3 board since I thought the Cinch and DexterOS only worked with the Dexter WiFi dongle (would be a shame to waste the built-in WiFi).


#3

Hi @darrell-little,
Nothing will work if the firmware is not up to date. I’m investigating as to why it isn’t. I’ll be back with some news asap

Quick question, now that you can get the wifi led to turn green, do you still have a firmware error?

Cleo


#4

Thanks! Maybe it will be helpful for some others also. It was a bit funny that the software was asking for a version lower than the current version. :face_with_raised_eyebrow:


#5

Yes, the firmware versions are incompatible, hence asking for an older version. We do have an update on the way that addresses that but it won’t be ready for a few weeks, at least.

Oh! I just figured it out! (at least I think I did)
Yes, the firmware cannot be changed when using a B+. At least not in this version. Argh, totally didn’t see that one coming. So sorry about that.
Would it be possible for you to boot once with a 2, or a 3? That will allow the firmware to change, and you can go back to the B+ afterwards.

Cleo


#6

Thanks, I’ll give that a try and report back.


#7

Looking good now. I have a GrovePi+ using a Raspberry Pi 2, so I just swapped them out. All the LEDs work now and going to try it out this afternoon. I’m glad that’s sorted out because I’m hoping to demo the GPG3 at the next Raspberry Jam in September. Thanks so much!


#8

Thank you for coming back and letting us know.
Closing this as solved, now.
Cleo


#9

This topic was automatically closed after 2 hours. New replies are no longer allowed.