[SOLVED] Github needs password for grovePi

I am following directions at :

But it is asking for a github password when trying to clone GrovePi into my Raspberry pi. WHY? How to work around this?

By the way, I am trying to get GrovePi installed in my Raspberry pi with the latest Raspbian OS intalled (buster). Any other snags I should be aware of?

To install GrovePi, please use this command instead:
curl -kL dexterindustries.com/update_grovepi | bash
It will take care of everything for you.

Also, I fixed the documentation. The proper line should read:
git clone https://github.com/DexterInd/GrovePi

Thank you for bringing it to our attention!

Ok, I did this but got the following :


So I tried git clone https://github.com/DexterInd/GrovePi, and that seemed to work, but I could not continue past sudo ./install.sh This is what I get:

There is no …/Dexter/Lib… does that come from the curl -kl… command you suggested?

It seems your raspberry pi isn’t properly connected to the internet. I just attempted the
curl -kL dexterindustries.com/update_grovepi | bash
and it works fine but it does require a working internet.

Can you do

You are right- but its strange, I could browse internet with the pi, but could not ping anything. I was on my school’s proxy, so I figured it must be some proxy rules they’re using.

Anyway, no matter what I did, I could not get the pi to use my phone’s hot spot. I had to reflash the SD card with a completely new setup and start over.

Now it is working, thank you very much

1 Like