[SOLVED] GoBox Mission 10 - IR Sensor not receiving

gobox
gopigo

#1

All is going well except the remote doesn’t seem to work. Even sticking it right up next to the IR sensor gives us no response, no values.

Any ideas?


#2

Hi @rexmagoo,

I have a couple of questions I want to point out:

  • Can you tell us what steps have you followed?

  • Have you followed the steps provided in the project’s README?

  • Do you have the latest drivers on your Raspberry Pi?
    We’ve been updating a lot in the past couple of weeks and the Remote IR project has been updated too.

  • Just to be sure, are you using the project that’s found on the following page - link here?

  • Have you enabled the IR Receiver from Advanced Communications icon?

I’m waiting to see what your feedback is.

Thank you!


#3

We had just installed the Raspian for Robots on a new SD card (as we had updated our other, older card to DexterOS to try that out). We immediately ran the DI Software Update to update the software. That update completed. We then clicked the “Advanced Communication” icon and enabled the IR. After reboot we went ahead with the Mission 10 instructions and created our Scratch program.

Neither the Mission 10 written guide nor the companion webpage make a mention of the github link you referenced. We’ll check that out tonight and see if that can fix our problem.

For reference: Here’s the Mission 10 page: https://www.dexterindustries.com/goboxmissions/missionten/

Thank you!


#4

Hello @rexmagoo
I haven’t forgotten! I got my remote out all ready for investigation tomorrow. I apologize for the delay
Cleo


#5

No problem. I tried a few things last night and I think the problem might be a bad SD card as the GoPiGo kept freezing up and/or taking a long, long time to just respond to simple things like opening a folder. So, I bought a brand new card and I’m loading Raspian for Robots on it now and will try again when I get home.

I’ll let you know if I have better results with the remote after that.


#6

@rexmagoo,

I can confirm the issue is on our side. Apologies for the extra work you had to go through.
I have a fix, it’s currently going through a sanity check. As soon as it’s available, I will let you know.

Again, I’m sorry about this but thank you a million for bringing it to my attention so it can get fixed.
:heartpulse:

Cleo


#7

Oh, good! Because I had the same problem with the new SD card (updates would seem to get stuck in terminal, or clicking on folders would do nothing) and I realized that it was really just the GUI that was frozen. If I closed the tab on my browser and opened a new dex.local and logged back in, everything would be updated/open. But then it would freeze again. I was beginning to wonder if it was a hardware issue.

I’ll hold tight until you let me know it’s good to go. (and how to proceed).


#8

Hey @rexmagoo,!

The fix is in! You will have to do another DI Update, then activate the IR server via Advanced Comms as it says in the mission.
I apologize for the bug… :frowning:

Cleo


#9

No problem. Thank you!


#10

Success!! The remote is working!

Thanks again!!!


#11

Yeah! :champagne:
Thanks for letting us know, and sorry again for slowing down your mission.

Have fun!
Cleo


#14

This topic was automatically closed after 25 hours. New replies are no longer allowed.