[SOLVED] GoPiGo Directory Permissions


#1

i’d like to be able to connect to my raspberry pi file system from Multi-Commander or basically just access the file system from windows. I have successfully done this but I cannot seem to give the right permissions r/w to the GoPiGo directory so I can edit/ replace files. I try to open that directory and it says I don’t have permission. I mapped the drive with DEX\pi credentials. I run the command ls -l, I can see everything belongs to root.


#2

Have you tried

sudo chown -R pi:pi ~/

?


#3

Unfortunately yes:

$ sudo chown -R pi:pi ~/Desktop/GoPiGo

still wont let me get in there from mapped drive. I mapped the drive with pi:robots1234


#4

Hey @paul.resinger,
could you share a screenshot of the multi-commander connection settings? I haven’t used that tool myself but maybe that will shed some light on the issue :slight_smile:

Frost


#5

Shot in the dark here. ~/Desktop/GoPiGo is a soft link. Maybe try ~/Dexter/GoPiGo and chown in there?

Btw, samba is pre-installed on Raspbian for Robots. I access my Pi that way.


#6

Thanks for all your feedback! I believe I got it working by using this:

sudo chmod 777 Dexter/GoPiGo


#7