[SOLVED] Gopigo don't respond


#1

Hello,
After a update, my gopigo don’t work.
I connect with vnc and with python i type this code

from gopigo import *
volt()

This is return -1
For all function

I don’t know what to do, i run a troubleshooting test, but i don’t know what to do.
Thanks for help

log.txt (6.2 KB)


#2

Hi @coulon,

Thanks a lot for sharing the logs, it looks like the update wasn’t proper. Can you run this program by typing sudo bash /home/pi/Desktop/GoPiGo/Setup/install.sh on the terminal and then try using your code again.

Please let us know if this helps,
-Shoban


#3

After update, it will work again but the servo and the ultrasonic sensor don’t respond.
When I type servo(20) the servo don’t move and make no noise
the ultrasonic sensor always return 0

There is another things to do ?

I made a second troubleshooting log log.txt (6.7 KB)


#4

Hi @coulon,

It looks like the update has been good this time, and the board does seem to be functioning good. So the problem might be with the sensors, can you send us a picture of your setup with the Sensors(Servo and Ultrasonic) connected to GoPiGo. Please make sure the servo cable orientation is as shown in step 4 here.

If you can send us video showing the exact problem it will great.

-Shoban


#5

I fix the problem with the ultrasonic sensor, i plug it on serial and it respond when i type us_dist(0)

But the servo don’t turn. I send you a picture of my GoPiGo.


#6

Hi @coulon,

Checking if the servo is functional by calling servo(20) might be a little too limited.
What we can do is to go through more positions and see if/how the servo reacts.

Check out this example code for the servo. It’s called basic_servo.py

If the servo is bad then it might make a sound when trying to reposition it or it might do nothing (the latter is less likely though).


Another way of figuring out if the servo is bad is to take an LED and place it on top of the connector.
Please handle the situation very carefully.
It’s better if you have jumpers (mother-to-mother).

Step 1

The first pin from the right side (face the GoPiGo robot towards you - just like in your picture) goes to the cathode of the LED. The pin from the left side goes to the anode of the LED. The middle pin of servo connector is let free.

Here’s a picture of the cathode & anode of an LED.



Step 2

Now run the following code:

from gopigo import *
from time import sleep

# we update the servo every half a second
# because after some time the command is canceled
# and hence, you don't get any PPM signal

while True:
    servo(180)
    sleep(0.5) 

Step 3

Check if the LED is emitting a weak light.
It’s a weak light because we have a PPM signal.
The important thing is to light up a little.

If there’s a weak light, then you have a faulty servo.


Success!

Thank you!


#7

Thank you very much,

The servo is faulty, we contacted our local seller to get a new one.

Sincerely,

Nicolas Coulon
nicolas.coulon@ac-strasbourg.fr mailto:nicolas.coulon@ac-strasbourg.fr


#8

This topic was automatically closed after 25 hours. New replies are no longer allowed.