[SOLVED] Gopigo is going in circles


#1

log.txt (7.3 KB)

Gopigo is going in circles. Left Wheel of GoPiGo not working.

Attached logs.

I am running “Raspbian for Robots”

I ran the basic commands on basic_test_all.py. I tried “i” and “k”. The result was that Gopigo started goining in clockwise and anti-clockwise circles. v command gave the voltage as 10.12V.

Please suggest what could be done.

Thanks!
Venky


#2

Hi @emailvenky

Looking over your report log, I can see that the encoders values don’t change at all on the left motor.
This means that the left motor doesn’t spin even though we send the command to spin.


Here’s a screenshot of a fragment of your log that clarifies the situation.
You can see the values on the left encoder stay at 0 during the testing phase - which is bad - it should change just like the values on the 2nd encoder.


So it would be great to send us a video with the robot upside down so that we can see the wheels while it’s running.
I think the DC motor is faulty and we need to confirm from the video that you need a replacement.

Thank you!


#3

What if the connection to the motor is bad? A loose wire could mean to the motor isn’t getting power to run the motor! It is getting some kinda power for the encoder to work but that may be separate. Not sure how the motors work exactly


#4

Video Link:

Checked the connections, they seem alright to me.

Amazon.com order number: 103-5960238-0043423

Thanks,
Venky


#5

Hi @emailvenky,

Your video link is broken.
Can you try upload the video with youtube or something similar?

Thank you!


#6

Same results with me. Can’t watch the video.


#7

Also uploaded on youtube:


#8

Did you assemble it properly? Maybe the wheel is stuck.


#9

Thanks for the video. Connections look good. I’d like one more test if you don’t mind.
Can you swap the motor cables? ie control the left motor with the cables that are meant for the right motor and vice versa. I’d like to know which motor will react.

Cleo


#10

I interchanged the connections. The same right wheel continues to work. The left wheel does not work though it is not stuck by any means. Hope that this is the final test… @RobertLucian


#11

Hi @emailvenky,

I’m sorry to hear it still doesn’t work.


Let me make a summary of the test you’ve done: you’ve only interchanged the connections (cables) and not the motors.
Finally, you ended up having the left motor connected to the right connector on the GoPiGo and vice-versa.

Having this setup, the only motor that kept on working was the right one, whilst the other one was “dead”, even though it wasn’t stuck by any means.


If this is what you’ve described, we can assume you have a faulty motor.
Before following the next step, please confirm here the situation.

After you’ve confirmed, please contact our support by following this website and go to General Questions and Feedback and briefly explain your situation and someone from our team will contact you for further procedures.


Again, I’m sorry for having this issue. Hope we can solve it ASAP.

Thank you!


#12

Yes, I confirm that you have summarized it correctly. Thanks for helping out in resolving this.


#13

Hi @emailvenky,

Thank you for your confirmation.

See you!


#14