[SOLVED] GoPigo "Pi Only" connection

firmware
dexteros2x

#1

I have a GoPiGo 3 and a Raspberry Pi 1 Model B+ (512 MB). I flashed DexterOS onto an SD card following the exact instructions on Dexter’s page. I have a wifi dongle (Edimax EW-7811Un according to its instruction manual) plugged in to the pi.

When I plug in with battery or USB, the lights on the Raspberry pi itself light up (and if I experiment by plugging in an ethernet cable connected to my computer, the yellow and green lights by the ethernet light up as well. However, this problem has nothing to do with that as I’m generally not having an ethernet cord plugged in. I only mention it because there’s a video somewhere that says if there’s a problem with your SD card image, those lights next to the ethernet port wouldn’t light up).

On the GoPiGo board, the LED flashes green for a little bit. GoPiGo appears on my PC as a wifi network option. I connect to GoPiGo successfully. The green LED on GoPiGo board stops flashing and starts staying green (however, the little antenna light on the GoPiGo board doesn’t light up at all… the one at the tip of the robot image’s antenna).

I can ping 10.10.10.10 from my PC. If I go to 10.10.10.10 or mygopigo.com, however, it will say “connected to Pi only” (or something very similar to that) in the top left corner and it will say I’m not physically connected to a robot.

I know my pi is talking to the gopigo (at least with power) because if I take the batteries out of the equation and turn it on just with a USB power cord plugged into the pi, the GoPiGo board still has LED’s that light up, so they must be connected.

I tried reflashing the OS, this didn’t help. I tried ordering an SD card from Dexter Industries with the OS already installed (it says v 2.2.0 on the sticker), same problem. I tried reseating the Pi and the GoPiGo onto the pi, same problem.

I have picked up a Raspberry Pi 3 Model B+ from my school’s lab now since it works without a wifi dongle (though I’m aware it might not work “as well” as it would with a Dexter dongle). I won’t have time to try it until late tomorrow (I work nights).

This project is due Dec 3rd and I’m running out of time. I don’t have a USB drive, so I don’t know if that matters (from my understanding it was for updating DexterOS, which mine shouldn’t need, or for storing pictures, which I don’t have a camera, etc). Hopefully I don’t need to physically get any more parts because I’m simply running out of time.

What could possibly be causing this issue? I recognize that perhaps plugging in this Pi 3 B+ might solve the issue, but I was hoping to get somebody thinking on it one day earlier rather than waiting until tomorrow only to find that didn’t help either.

Thank you!


#2

Hello @donmtobin

The issue you’re currently facing is that the GoPiGo3 needs its firmware updated, and the Pi 1 B+ is unable to do that for you. The Pi 3 will be able to do the job.

Also we have a new DexterOS up (2.2.1) which handles that firmware updating better.

The firmware updating is done only once. Once it’s done, you will be able to return the PI3 and use your Pi1. I would recommend downloading the new DexterOS today. Tomorrow swap the Pis, boot up using USB power (the batteries may be in, as long as USB power is also in!) The firmware update will happen automatically and be totally transparent to you except for a bit longer boot time.

You will know it will have worked once the antenna led turns on.

Cleo


#3

Hi Cleo,

So I woke up not too long ago and read this. I had already switched the Pi 1 out for the Pi 3 at work last night, so all I had to do this morning was plug it in. I tried it without the battery first and got a blinking purple light, which I understand to mean the pi itself isn’t on?

I’ve now plugged in the batteries first, turned on the GoPiGo, then turned on my USB power cord. Green blinking light now, no antenna light, and no GoPiGo appearing in my wireless hotspots. It’s been several minutes since I’ve plugged it back in. Does the firmware update take a very long time? (Since then, I have left it with the green blinking light with everything on for more than 20 minutes, still nothing)

Does my Pi 3 need a wireless dongle despite the fact that it should have native wifi? I’ve gone from at least being able to connect to GoPiGo (and getting a “pi only” connection) to not seeing any GoPiGo connection at all now. :frowning:

Edit: to clarify, I have seated the microSD I got directly from Dexter industries with DexterOS in the Pi 3 B+, which should be V2.2.0 according to the sticker it came with.

Edit 2: I have since tried plugging my wifi dongle into the Pi 3 and now the wifi dongle doesn’t light up/work like it used to on the Pi 1

Edit 3: Now here’s a weird thing. I tried plugging in an ethernet cable to see if the yellow and green lights still lit up when I did: they do NOT.

Edit 4: On the back of the Raspberry Pi 3 B+, there is only one red light marked PWR. The ACI light next to it is not lit up. I have reseated the MicroSD card. This MicroSD card works on the other Pi, so I don’t suspect it’s a bad image (the other pi was able to actually broadcast a wifi network named GoPiGo on its own with this SD card)

Final edit: I have it plugged in USB (no battery), the green LED on GoPiGo is flashing steadily. I left the wifi dongle plugged in (it was plugged in before turning on) just in case, and I’m leaving it on in this fashion while I go to work. I’m hoping it’s just that this firmware update you speak of takes a loooong time or something.

But if you have any more ideas, please let me know. I desperately need this to work, my project is due on 12/3 and I can’t even get to coding yet.


#4

Hi, Looks like I have “PI only” connection issue.
I have GoPiGo3, Raspberry Pi 3 Model B, using 8GB SD card with DexterOS V2.2
When I plug in with battery I see solid red and blinking green light on Raspberry pi3 , green flashing power light on GoPiGo. GoPiGo appears on my PC as a wifi network option. I connect to GoPiGo successfully. The green LED on GoPiGo board keeps flashing.
I can go to 10.10.10.10 or http://mygopigo.com/, however, it will say “connected to: GoPiGo (Pi only)” in the top left corner and it will say I’m not physically connected to a robot.

I tried to ls /dev/spi* on terminal which returned “no such file or directory”
Need help here…


#5

Hello @Ganesh_Gurusiddaiah and @donmtobin

Both of you are facing the same issue. To get your robot up and working you will need to:

  1. Download the newest DexterOS, which is 2.2.1 (it came out at the beginning of this week).
  2. Install it on an SD card using Etcher per this tutorial .
  3. Install this SD card into the Pi.
  4. Power up using the USB port on the Pi (batteries may be connected too, the key thing is that the first boot be done with USB power).
  5. Let DexterOS work, it will take a while, a good 5 min.

If you don’t use USB power on the first boot, there’s a risk of the SD card getting corrupted. We’re hard at work on DexterOS 2.2.2 which will address this issue but it’s not ready yet for release. @donmtobin I suspect this is why you are currently in a no-boot situation.

We’re really sorry for this extra hassle.
Cleo


#6

Hi, I almost forgot to reply about this due to a hectic schedule. Turns out, this did work. I was using battery first and turning on GoPiGo, which as you noted, may have been corrupting my OS.

I re-downloaded v2.2.1, re-flashed it, used USB only, left it alone, when I came back the antenna light was lit up and it was working fine!


#7

wooohoo! Thanks for coming back and not leaving us hanging.

Really sorry you had to deal with this issue though. We are taking steps to avoid this in the future (2.2.1+ is the very latest OS, and all it does different than 2.2.1 is avoiding the need for USB power).

Cleo


#8

This topic was automatically closed after 2 days. New replies are no longer allowed.