[SOLVED] GoPiGo Servo calibration


#1

How can I re-calibrate the servo? When I say 90, using the basic script it is a little to the left. I tried to adjust mechanically but it is the best I can get. When I put it at 100 it is perfect 90.


#2

Hi Peshko,

Due to the design of servos, every servo performs slightly different. A signal that sets one servo to 90 degrees might set another servo to 80 or 100 degrees. Since the servo calibration is hard-coded into the GoPiGo firmware, I recommend that you add an offset of 10 to the servo position to get the angle you need.


#3

To revive an old thread, I can tell the servo to make Dex ‘look’ to the right by setting it to 15 degrees, but I can’t tell Dex to look to the left by setting it to 195 degrees because that’s not a valid parameter (in Scratch, anyway). So Dex can’t look all the way to the left. What could I do in this case please?


#4

You could try removing the servo horn and reinstalling it rotated by one notch.

Are you using the GoPiGo, or the GoPiGo3?


#5

Hello @andrew2

Have you tried setting it to 165 instead of 195 ? (that would be 180 - 15 degrees, instead of 180 + 15 degrees) How does it behave with 165?

Cleo


#6

Thank you Matt and cleoqc. By undoing the screw on the servo horn and repositioning it by one notch (which was quite a large increment) I can now have Dex do the following:

rotate to 1 - turns to Dex’s right (trying to rotate to 0 causes the servo to rotate a bit too far and it sits there vibrating, probably trying to push past its limit)
rotate to 85 - looks straight ahead
rotate to 170 - turns to Dex’s left

So presumably I just need to scale any angle calculations to the nearest whole number between 1 and 170.

Thanks.


#7

This is how I ended up scaling the calculations for the servo. It seems to work ok.