[SOLVED] GoPiGo2 Power Battery Pack Showing 0V. Max input voltage?


#1

Hi.

Looks like I have a problem with the battery pack. I connect each one of the batteries to it, then turn the ON switch in the board and nothing happens (e.g no R.Pi3 lights at all)

I have a multimeter and made voltage test to the 9V connector (of the pack) and there is no output voltage at all ! 0V !

Then I made the same test to each one of the batteries, they are brand new and they are supplying the expected voltage.

Is possible the connector is defective, I’ve seen other posts of people having power problems with this pack. What next ?! I need this thing working …

Extra Q: What are the Min and Max input voltage specs of the board ?

  • Best regards

#2

Hi @JA_Lopez,

So, you have an issue with the battery connector that goes to the GoPiGo.
I may suggest you to measure the voltage across the 2 terminals of the battery pack. It requires removing the battery cable.

I think it would be useful for us to have a couple of pictures of your battery pack + cable + connectors. Maybe we can see something that doesn’t go accordingly.
Also, some pictures of your whole setup (the GoPiGo robot) would be really nice to have here.


Looking over the GoPiGo2 board’s schematics I can see the following regulator used for supplying power.
Giving a quick look into LM2576S datasheet I see it can accept a high range of input voltage: from 5V up to 60V. We haven’t experimented with that high voltages and I’m thinking that’s better to stick with the battery pack voltages. Input voltages between 5V and 15V should be reasonable.

Thank you!


#3

Hi Robert,

While I was taking the pictures today I also made some new measurements. According to your picture I used those 2 terminals and got 0V (yesterday and today). Then I made again the measurement and got ~10.9V (problem solved?).

Its possible is an open circuit issue, my theory is that my AA rechargeable batteries are slightly thicker than normal AA, so if press them a little bit harder against the battery pack I get my ~11V, if not I get 0V again. Its hard to believe though, through visual inspection seems everything is doing contact …

BTW thanks for the LM2576S info.

Regards


#4

Hi @JA_Lopez,

I got myself the same problem before.
I tried to use rechargeable batteries and I had the same issue.

The rechargeable batteries are slightly thicker than the normal AA batteries, so I think you may need to fasten them with some very small ties. You can find them at any hardware store.

It’s kind of unfortunate since you can’t find on the market bigger battery holders than the standard ones.
Please keep me updated on how it goes for you.

Thank you!


#5

Hi Robert,

Still I prefer de rechargeable, in the long term hopefully I will spend less. I have the GoPiGo already powered and running, already making tests with my wifi - ssh - python development environment. You can mark this thread as solved if you want.

Regards


#6

Hi @JA_Lopez,

Yeah, that depends on what you’re planning to do with it. So it’s use-case dependent.
If there’s anything else, please let us know and we’ll try to help you as much as we can.

I’ll close the topic now.

Thank you!


#7