[SOLVED] GoPiGo3 board not working


#1

Hi,

I’ve just received my GoPiGo3 starter kit and the board doesn’t appear to be working, and I’m not sure if there’s anything else I should try…

Here are the steps I followed:

  • Assembled robot as per instructions and switched on (with battery pack).

  • Green light flashed, but didn’t finish booting (I left for around 10 mins).

  • Disconnected power to reset and try again, still no luck.

  • Connected HDMI cable to check Ras Pi status, but no output at all

  • Downloaded Dexter OS and re-installed on SD card. Ras Pi now boots ok.

  • Power LED on GoPiGo board flashed blue for a while, but went off.

  • Could connect to Ras Pi through bloxter.com.

  • To diagnose, I replaced OS with Raspbian for Robots and ran diagnostics - It couldn’t find the board.

  • Now, there are no lights on the GoPiGo3 board at all (this is connected through the USB power

  • When I connect the battery pack, the power button doesn’t switch it on, but holding the power button does turn on the Ras Pi (but still no lights on the GoPiGo board). Letting go of the button loses power.

Any suggestions would be greatly appreciated.

Cheers,
Darren.


#2

I just managed to resolve this myself today, by re-installing the firmware from the GoPiGo3 folder on the Rasbian for Robots image.

Once the controller board came back up, I re-installed Dexter OS on the Pi again and everything works ok.

Something must have become corrupted in the firmware in the setup process.


#3

Good! It’s generally a good idea to update the firmware on new robots from Dexter Ind. had issues similar issues with my GoPiGo3!