[SOLVED] GoPiGo3 connection problem

I have taken out my GoPiGo3 robot again for the first time in a very long while, and I am having similar connection issues to when I first tried to use the robot, but I forgot how I fixed them.
The SD card is DexterOS, I have plugged in the power supply, the USB, and the WiFi dongle.
When I turn it on, the power light is green and blinking. It stays that way if I don’t do anything. When I hold the power button down, the light goes red, blinking a bit faster, then eventually turns purple, blinking at about the same speed as green. If I release the button, the light turns off. The light that indicates WiFi is never turned on, and I don’t see the network on my computer either.
The red light on the bottom green board is on.
Attaching a Ethernet cable doesn’t really seem to do anything.
I have seen the Connect & Learn tutorial, but the problem is that the green light never stops flashing unless I do something, and the WiFi light doesn’t come on.

I am probably forgetting something I should do, it would be great if anyone has advice.
I am equally thankful if there is a similar post to this which might solve the issue I am having.

Hello @nonohoriuchi

It does sound like your SD card is corrupted. The good news is that you can re-create a new SD card by following these steps

You will also get the latest version of DexterOS that way too.


Thank you, that worked! How did you know the problem was coming from the SD card? I’m curious to know and it might help me fix problems like this quicker in the future.

Nevermind, follow up question;

I’ve replaced the batteries on my robot since they were running low, (AA alkaline batteries, 1.5 V each) , but my robot says the voltage is too low, 4.1something V. It only turns on when I plug the wall adapter in (red battery light). The batteries are brand new, I’m not sure why this is happening.

Just to be clear, are you using 8 AA batteries?

Yes, I am.
Strangely, the problem has fixed itself. It seems to only succeed if you push the power button immediately after plugging in the power source. I still don’t know why that happens, though.

Immediately? Like within the very next second? I’ve never heard of something like that. This would be a first. Would it be possible too to have a video of that?

Thank you!

Hi, I tried to reproduce the problem, and I found out that it’s not about the timing of the button press, but rather whether the robot moves.
When I try to turn on the robot, I do so by holding the robot in both hands, so it moves a bit. The slightest force on the plug/wiring of the battery pack causes the power to shut down immediately, and I have to try again. I could take a video of that if needed.
Sorry for the confusion.

Hmm, that sounds like a ripped wire of the battery pack. Do you have a voltmeter around to measure the battery’s voltage while you move the wire a little bit?

If it’s a bad cable, then at some point you should read 0V on the voltmeter. In that case, you’ll need to get a replacement.

Sorry for the delayed reply. Yes, it turned out to be a ripped cable. It was a very small part, so it took a while to find it. I wrapped some tape around it and it works perfectly for now. I will get a replacement if it gets damaged more, though. Thank you so much RobertLucian and cleoqc for the help!

1 Like

Thanks for letting us know, @nonohoriuchi!

This topic was automatically closed after 5 days. New replies are no longer allowed.