[SOLVED] GoPiGo3 doesn't broadcast wifi and power issues

#1

Hi, I just assembled my University GoPiGo3 robot and I have issues with connecting to wifi.
When I connect it to the battery pack the light gets green on the power, but there is no response on the wifi antenna light. Also, the light on the raspberry pi board is solid red on J1 and blinking green on L2. I can see Gopigo wifi in my networks, but there’s just a question mark and still no lights on the board and no internet. I thought the batteries might be weak so I tried to connect it with the usb power. At first the power light is red and one of the lights on raspberry pi is solid red and the other is blinking green (don’t know why). When I push the power button the power light is not solid green like with the batteries (don’t know if it is normal) - it’s like bluish-pink blinking light. The raspberry pi lights is just solid red, and there is no blinking green light. Just to note I purchased the entire kit, so the micro sd card is from the kit with DexterOD v2.1.2 on it.

#2

Hello @irma.ravkic

I’m sorry your GoPiGo is being problematic. Can you please update your SD card to 2.2.2 ? We have taken care of the problem in that version but not all kits have received an updated SD card unfortunately.

The instructions to install the newest DexterOS are here:
https://www.dexterindustries.com/dexteros/get-dexteros-operating-system-for-raspberry-pi-robotics/

Cleo

#3

Thank you. Now the Wifi works.

#4

Great! Apologies again for the hiccup in getting started. And thank you so much for coming back and confirming your robot is up and running.

Cleo

#5

No problem. I am used to the headaches related to (mobile) robots :slight_smile:
Thank you for your fast help!

Best,
Irma