[SOLVED] GoPiGo3 motors are not rotating on basic test


#1

Hi,

Just got GoPiGo3 adv. kit and assembled it.

I am able to do following,

  1. ssh and vnc client to login to the pi over wifi network

  2. Ran the install script for python gopigo

  3. LED next to power button is GREENON (connected 8AA batteries)

  4. LED for Dex’s wifi antenna is NOT ON.

  5. Python program below does not do anything

from gppigo import *
import sleep

fwd()
sleep(2)
bwd()
sleep(2)

I attached the diagnostic log.log.txt (6.4 KB)

Appreciate any help.


#2

Hello @vms

Based on the diagnostic logs, you don’t seem to have battery power. The GoPiGo3 will not trigger the motors if it doesn’t have enough voltage for it. The Pi power is not enough.

Cleo


#3

Hello @cleoqc,

Thanks for the pointer.

I suspected loose connection in the cables that go from motors to the dex board.

After reattaching the wires, I did not see any difference .

I have attached some pictures of the device.

Appreciate any thoughts.

Vms


#4

@vms ,
thanks for the photo, the cables do look fine.
Could you run the program called Read_Info.py found in /home/pi/Dexter/GoPiGo3/Software/Python/Examples, and post the results please?

Cleo


#5

@cleoqc,

Read_Info.py file is not present under GoPiGo.

Looks like the files i received were older.

I cloned the following and ran install.sh and Read_Info.py
https://github.com/DexterInd/GoPiGo3

Message:
No SPI response. GoPiGo3 with address 8 not connected

Do I need to upgrade firmware or anything else?

Thanks
vms


#6

@vms,
I just want to make certain that you are running Raspbian for Robots and not just Raspbian. (Raspbian for Robots has a little Dex on the desktop)

Read_Info.py has always been released with the code as far as I know. Is it possible that you happened to check under ~/Dexter/GoPiGo by mistake and not ~/Dexter/GoPiGo3 ? I know i do that all the time.

Our preferred method for installing the GoPiGo3 would be
sudo curl https://raw.githubusercontent.com/DexterInd/Raspbian_For_Robots/master/upd_script/fetch_gopigo3.sh | bash

but what you did is basically the same thing if you cloned it into /home/pi/Dexter/GoPiGo3. Or did you choose another folder?

And finally, could you paste the content of your /boot/config.txt file?

Cleo


#7

@cleoqc,

Yes i am running Raspbian for Robots.

There is no ~/Dexter/GoPiGo3 folder.

After I ran the command below the folder is present.
sudo curl https://raw.githubusercontent.com/DexterInd/Raspbian_For_
Robots/master/upd_script/fetch_gopigo3.sh | bash

I have attached the config file.

Thanks.

config.txt (1.74 KB)


#8

@vms.

First I apologize, I missed one crucial point in your very first post.

You’re using a GoPiGo3 as seen in the photo.
However you were using the gopigo library
import gopigo

You need to use import gopigo3, or import easygopigo3 (this one gives you easier to use commands, so it depends on your level of expertise and your goals)

You say there wasn’t a ~/Dexter/GoPiGo3 folder. Did you get an SD card with the kit or are you using an old one? Either way, your card seems not up to date. I would recommend doing a DI Software Update. It will probably take a long time as the Raspberry Pi Foundation has done some extensive changes in the last couple of months and the Software Update will make sure you get them all (security updates, new editors…)

As the GoPiGo3 folder is now on your card, did you try the Read_Info.py program ?


#9

Success.
After I updated the DI software, motors started spinning.
The servo program also works.

Thanks @cleoqc for help.

The code seems to have changed a lot between 3 and earlier versions of GoPiGo.

I want to program following,

  • Avoid obstacles using distance sensor. Do I need the ultrasonic sensor for this ? I just have distance sensor.

  • recognize a face with help of pic taken from onboard camera and greet say hello Tom or Joe

  • indoor routing. Go from one office to another… off course on same floor. Do I need gps go this? May be CAD drawing?

Thanks


#10

@vms:

  1. The distance sensor should work just fine for this!
  2. This might be more complicated, but we have some examples on how to use emotion recognition with Python here.
  3. Unfortunately a GPS won’t help much. But the encoders are so good on the GoPiGo3, this should be doable with a map.

#11

#12

@vms,
thanks for letting us know it’s now working. Again, my apologies for not seeing the discrepancy between GoPiGo models right from the start.
And yes, the code has changed a lot. We do think it’s for the best though.

@john already answered a bit about your extra question. I just wanted to add that the line follower might be good for indoor routing, if you don’t mind installing a line on your floor. Otherwise, a map would be good. A GPS might not solve your issue because the Grove GPS doesn’t work all that well indoors (it’s fine outdoors).

Cleo