[SOLVED] GoPiGo3 Starter Kit


#1

I have a GPG3 Starter kit that came with a microSD card which I inserted into the slot on the bottom of Raspberry PI3 as instructed. When I power on the green light on the Red board blinks continuously and never goes solid. Is the OS not on the microSD card? In the same package as the microSD is a larger SD card. What do I do with that? Very frustrating…


#2

Sometimes it is useful to work one layer at a time. The starter kit comes with a “mains” power supply.

When you power the RaspberryPi with the mains power supply (battery cable not connected), what do you see on the RPi indicator lights?

Do you have the required “Dexter WiFi Dongle” (or alternative) plugged in? Do you see the “GoPiGo” WiFi network to connect to from your computer?

You will not be able to drive your bot, but these steps verify the Raspberry Pi layer (Raspberry Pi board, microSD card with DexterOS, and WiFi dongle) are working.

(BTW, I am not connected with DI - only a bot lover like yourself.)


#3

@ras3601

@cyclicalobsessive has the right approach, for sure. Just a few extra things.

You most likely do not have a Dexter Industries Wifi dongle, nor do you need one. All our kits come with a Pi3B which is already wifi enabled so you don’t have to worry about that.

As for booting the Pi with the wall power supply, it’s definitely the way to go. Make sure you have the USB drive in one of the usb ports. If the Pi boots up, it will write log files onto the usb drive which you can share here afterwards. It will let us know what’s not working.

Thanks,
Cleo


#4

I tried wall power as well. When I connect to the Pi via HDMI and a monitor I get a screen of errors. Does this mean the SD card is bad, should I try reloading the OS? I am able to load other OS on the Pi with no problem. I have access to an alternate card, I will try that and let you know. I will also check the USB drive for anything of use.


#5

I tried wall power with the main power supply same result. I will check and note the indicator lights but as I note below, When I get to the RPi via HDMI and monitor I get a lot of errors on screen. I will try to get that info as well…


#6

Also, no I do not see the GoPiGo network and the robot head does not light up. I will try an alternate Dexter OS card when I get a chance.


#7

It does sound like the card is bad. I’m very sorry. Each card gets checked but sometimes they get corrupted after the check.
The good news is that you can re-image it. It’s doubtful the card is physically bad (but it is a possibility)

You can follow this step-by-step tutorial to re-image it.

Let us know how it goes!
Cleo


#8

I burned a new card and the Robot came right up. Thanks for the advice and help. Should have done that from the start I guess.


#9

Glad to see you’re up and running! Thanks for letting us know !

Cleo


#10

This topic was automatically closed after 2 days. New replies are no longer allowed.