[SOLVED] GoPiGo3 with address 8 not connected

gopigo3
faq

#1

Hello,

When running the GoPiGo 3 from DexterOS everything works fine.

Took image 2017-09-28-Dexter_Industries_jessie.img to install Raspbian for Robots (copied the img already several times to SD card, so that is not the problem)

I am able to connect through ssh and VNC.
However from Raspbian for Robots, the GoPiGo3 is not responding (tried python and scratch).

As suggested in other posts I ran the following commands (using ssh):
sudo curl -kL dexterindustries.com/update_gopigo3 | bash
python /home/pi/Dexter/GoPiGo3/Software/Python/Examples/Read_Info.py

The last command gives me the following response:
“No SPI response. GoPiGo3 with address 8 not connected”

I already activated the SPI using raspi-config and to be sure added the line “dtparam=spi=on” to /boot/config.txt

Does anybody have any idea?

kind regards,

Jacco


[SOLVED] No SPI response. GoPiGo3 with address 8 not connected
#2

Hi @jaccoprovoost,

What does executing bash GoPiGo3/Firmware/gopigo3_flash_firmware.sh show you? And does this solve your issue? You can check it again with Read_Info.py script.

gopigo3_flash_firmware.sh is found in the repository, so I suggest you clone the repository and then run the given command.

Thank you!


#3

Installed the firmware using the “DI software update” icon on the desktop. After this it indeed worked.

Thanks for your help!


#4

Hi @jaccoprovoost,

That’s great to hear. It means your GoPiGo3 didn’t have the firmware flashed.

Thank you!


#5