[SOLVED] Grove Pi Tests fail

grovepi
firmware

#1

Hi
I had a working Grovepi Board on my Raspberry Pi 4 running the latest Raspbain (2017-04-10-raspbian-jessie) which suddenly fai stopped working.

I did some research and loaded up 2017.04.02_Dexter_Industries_jessie image and ran the trouble shooting tests.

IO have attached the log, hoping some one can hlog.txt (6.4 KB)
elp.


#2

Sorry for my typos.
Michael


#3

There’s an error with the I2C. I Just wanted to verify that there is only the Raspberry Pi 3, not a 4th one. So it worked before but now it doesn’t? Have you tried updating? Also try updating the firmware, that sometimes helps.


#4

Hi graykevind,

I hhave to GrovePi Board fitted to a Raspberry Pi 3 Model B, and have been unable to update its firmware, with it showing a 12C access error. I also fitted it to another Raspberry Pi with the same results.
Am I look at having to buy a new Board?

I will try again to update its firmware, as a final thought which firmware version should I be using?

regards Michael


#5

Hi,
I have just ran the GrovePi update Icon and tried to update its firmware, sadly it faild.
Log file is attatched.
Dexter_Software_Update_log_2017_04_30__12_45_41.txt (1.3 KB)
Dexter_Software_Update_log_2017_04_30__12_18_23.txt (225.2 KB)

Michael


#6

Same problem here. I feel that it does that with the latest RPi firmware update (not the GrovePi firmware).


#7

Huh, not sure what’s going on.


#8

Hi @whimickrh,

It looks like the avrdude isn’t responding and hence the firmware update is failing, Can you show us a picture of your setup and also tell us how you are powering the GrovePi. It would be great if can you try another fresh firmware update with GrovePi by running the following command on the terminal

sudo bash /home/pi/Desktop/GrovePi/Firmware/firmware_update.sh, and post the pictures of what you see on the terminal on running this command.

Note: Make sure with no sensors connected to GrovePi while doing the firmware update.

-Shoban


#9

Thankyou for taking the time to look into this problem.
I have done as you asked and tried to flash these versions

grove_pi_firmware.hex
grove_pi_v1_2_2.cpp.hex
grove_pi_v1_2_5.cpp.hex
grove_pi_v1_2_6.cpp.hex
grove_pi_v1_2_7.cpp.hex
old_grove_pi_firmware_1_1.hex

All gave the same results.

I have enclosed some imageAfter_Flashing.txt (1.2 KB)

files, and the output from the Screen, I hope these help.

Regards Michael


#10

Hi @whimickrh

I think your GrovePi has to be replaced.
We deeply apologize for creating such an inconvenience.

If you’ve bought the GrovePi directly from us, then I’m kindly asking you to contact us here - search for General Questions and Feedback section.

Otherwise, please contact your distributor / reseller for the replacement.

Thank you!


#11

#12