[SOLVED] GrovePi not detected


#1

Hello,

I bought a Raspberry Pi 3 and a GrovePi in order to test some sensors. After a few days of configuration and tests, I haven’t yet manage my rpi to detect the GrovePi. I followed a lot of tutorials, installed Raspbian for Robots, edited some files, …
But “sudo i2cdetect -y 1” still doesn’t detect anything. I have just updated the firmware and nothing changed.
Did I do something wrong?

Thanks!

Edit : The led on the GrovePi indicates that it is well plugged.


[solved] Grove High Temperature Sensor
#2

Hi Abrikot,

Here’s what we suggest you do.


Try one of our python examples and let us now what’s printed on the terminal. Please make a screenshot share it here.

Get yourself a Grove LED board, connect it to D4, open up a terminal and type the following commands:

$ cd Desktop/GrovePi/Software/Python
$ python3 ./grove_led_blink.py

If everything seems to be working and your LED is blinking, then hooray.
Sometimes, the GrovePi isn’t detected when testing with i2cdetect, but still works communicating with it.

You can also test with any other sensor/module, but I think the Grove LED board is the simplest of all.



If the above procedure I gave you failed, then go to RasperryPi’s desktop and hit the following buttons in the right order so we can debug the GrovePi. Attach the log.txt here.


Thank you!


#3

Hi,

Thank you for having replied !

Unfortunately, I’m a trainee and I can’t have more than what I already have, i.e. a temperature sensor. Besides, there is no official library for this sensor for Rapsberry Pi… So I can’t verify if the GrovePi is really working, until I have developed something. But, in order to develop something, I need to know if the GrovePi is working!

Well, here is the log file : log.txt (6.1 KB)

Thank you!

Edit : after a few new tests, I got some values - which are changing when I plug or unplug the sensor. Therefore, I think the GrovePi is working without being detected… That’s strange !
The values are weird, but that’s a starting point ! I’ll try to fix it.

Edit 2 : I ran an i2cdetect and… The GrovePi showed up. Perhaps it only needed to be read once before being detected ?


#4

Hi Abrikot,

I think it’s something with the GrovePi’s firmware.


So I’m suggesting you follow the 3 steps found in the next screenshot and after that, please make a screenshot of the terminal that’s opened in the background and post it here (aka Update in progress - Do not close this window!)

Then retry with i2cdetect to see if it’s functional after you reboot the system.


Seeing that you only have a sensor at hand, I can give you an unofficial library for that one in particular (the high temperature sensor from seeed). Since it’s unofficial, there might be problems with it.

You have to do the following:

$ cd ~/Desktop
$ mkdir unofficial
$ cd unofficial
$ git clone -b develop https://github.com/RobertLucian/GrovePi.git
$ cd GrovePi/Software/Python
$ cp grovepi.py grove_hightemperature_sensor/
$ cd grove_hightemperature_sensor
$ python3 high_temperature_example.py

Please, take a look in the example program so you know what you have to do. You’ll have to use A0 analog port with the sensor.
By the way, you can insert the tip of the sensor in water if you want to measure the temperature.
Apropo, only the tip of the sensor senses the temperature.


Thank you!


#5

Hi,

I didn’t manage to make a screenshot within Raspbian, but I copied/pasted the result in this log file (4.4 KB).
i2cdetect works well after this update, thanks!


Thank you for this library, it’ll help me a lot! There are always some strange measures (25°C instead of something like 20°C), but that is only a prototype. So there is no problem :wink:


#6

Hi Abrikot,

I’m glad you made it work.
If you have anything on your mind (project, bug, idea, etc), please share it with us.


Also, you can now cd to ~/Desktop/unofficial/GrovePi (the folder I’ve talking about in my last post) and type git pull, and it’ll update with some new changes that were added today.


One last thing: the room temperature sensor, which is found on the high temperature module is much more precise than the high temperature one (aka the K Type sensor), which is found at the tip of the probe.
It’s common to see the measurements of the K Type sensor fluctuate.


Thank you!


#7