[SOLVED] GrovePi Zero not working - no 0x04 address

grovepi
installer

#1

I’ve been fighting with your Grove pi zero all day.
I’ve successfully run the installs.

cd /home/pi/Desktop
sudo git clone https://github.com/DexterInd/GrovePi
sudo chmod +x install.sh
sudo ./install.sh
pip install grovepi

After all that I cannot get it to work!

when I run this

i2cdetect -y 1

there is no 0x04 showing up…

When I run this script:

import grovepi 
button = 3
grovepi.pinMode(button,"INPUT")
while True:
    button_status= grovepi.digitalRead(button)	
    if button_status != -1:	
        print "button on"

I get nothing… the value is ALWAYS -1, I’ve tried ports 3

I’m using a brand new Zero W and brand new GrovePi, Raspbian Stretch full version Scandisk Ultra 16 GB

HELP!


#2

Hi @pete.hollyer,

That seems overly complicated. Just run the following command:

curl -kL dexterindustries.com/update_grovepi | sudo bash

And make sure you do this as the pi user.

After you have run the above command, go to /home/pi/Dexter/GrovePi/Firmware and execute bash firmware_update.sh to flash the firmware to the GrovePi.

After all these, you’ll have a functioning GrovePi.

Thank you!


#3

Thanks!!!
Up and Running!


#4

I’m glad to hear that. Marking this post as solved.


#5