[Solved] Installation fails - no pi user

I can not seem to get GrovePi+ installed…

I have a minimal install of Rasbian, without pi user, for security reasons… Without the GUI stuff…

So I had to modify install.sh and update_grovepi.sh to not refer to pi but to my home…

(Personally I find it strange to refer to the pi user, it is recommended to remove the pi user for security reasons…)

After I run ./install.sh (as root) I get:

roland@pi:~/GrovePi/Script $ sudo ./install.sh
./install.sh: line 11: /home/roland/Dexter/lib/Dexter/script_tools/functions_library.sh: No such file or directory
Special thanks to Joe Sanford at Tufts University. This script was derived from his work. Thank you Joe!
./install.sh: line 48: feedback: command not found
I2C-dev already present
i2c-bcm2708 already present
spi-dev already present
./install.sh: line 68: feedback: command not found
i2c1 already present
i2c_arm already present
The user roland' is already a member of i2c’.
./install.sh: line 86: feedback: command not found
./install.sh: line 87: /home/roland/Dexter/lib/Dexter/script_tools/install_avrdude.sh: No such file or directory
./install.sh: line 88: create_avrdude_folder: command not found
./install.sh: line 89: install_avrdude: command not found
done with AVRDUDE for the GrovePi

Something goes wrong here… feedback: command not found

Can anybody help me out here???

1 Like


From the standpoint of troubleshooting, I would recommend two things:

  • First and most important - can you reproduce this on a “stock” system with the “pi” user as specified?

  • Have you tried flashing a different SD card, and/or using a different flashing tool? Maybe use a different port, or use the system’s native SD card reader? (Or, avoid it if that’s what you’re using.)

How good are the cards? Are they really good, GENUINE cards from SanDisk or Samsung? (Micro Center branded cards are excellent too, and a lot cheaper.)

Avoid on-line sites like Avita, alibaba, eBay, or the like as there are rumors that at least some of these cards are counterfeit. (Look up “Ghost Shift” online. It’ll be an eye-opener.)

I am saying this because the later versions of the Pi have stricter timing requirements, and el-cheapo cards just don’t do the job.

Try these things and let us know what happens.

Dear Jimrh.

Thanks for your response.

To start with the 2nd bullit: The SD card is fine. That is a SanDisk. That image is working fine for over a year now… That is not the problem here. :slight_smile:

That brings me to bullit 1. The problem lies in the absence if the pi user. That is the problem. The scripts expect the pi user to be there. That is very, very strange… That is not the way we are used to in Linux. In Linux the installation should be independent of a specific user.

So I kindly ask Grove to look into this and supply us with installation scripts that do not require the presence of a specific user… Or do it like Oracle and say that the installation requires a Grove user…

Hanging it up to the pi user is a security hazard…

1 Like

Thank you for the additional information.

Two points to consider:

Solid state memory of any kind has a limited lifetime depending on the number of times you write to it. For something like an active operating system, that lifetime can be remarkably short because of the almost continuous updates to the media.

The Dexter operating system images are not “normal” Linux distributions in the way you seem to expect.

A “normal” Linux distribution is designed to be very generic. It is designed to be used for a wide variety of possible purposes and a wide variety of use-cases. The design of a “normal” distribution and it’s security model reflect that.

The Dexter robot system images are not designed to be general purpose operating systems.

They are designed for a very specific use-case, (i.e. classroom or experimenter use), where a simplified user and security model isn’t a problem.

They are designed in such a way that if a bunch of classroom students accidentally damage the installation, the instructor can repair it very quickly and easily.

They are designed so that an experimenter or hobbyist can tweak and experiment with them without needing a college degree in robotics.

As a result, these scripts are available for you to modifiy, to meet whatever need you may have.

If you need the scripts to do something they weren’t originally designed to do, feel free to modify them in whatever way you want. All we ask is that you share your modifications with the rest of us.

Two examples come to mind:

  1. @cyclicalobsessive has a robot named “Carl” that he is programming to be totally autonomous - capable of wandering around, exploring his environment and automatically retuning to his charging station when his batteries get low.

  2. My own robot, named “Charlie”, isn’t designed to do anything specific. It’s there for me to experiment with, try to learn from, and have a lot of fun while I do it.

Currently I am working on a project where I use the Pi’s camera to send a “First Person View” of what the robot sees back to a browser window, allowing me to control Charlie with a joystick in the way a “bomb-sniffing” remote-control robot would be used.

Others are using their robots with systems like the Jetson Nano for more advanced robotics experimentation.

The sky’s the limit!

The only caveat is that you have to decide what particular part of the sky you wish to explore and you have to figure out how to get there. The only thing that limits you is your imagination and skill.

Of course we are here to help you and give you the benefit of whatever experience we have.


Remember, robotics is supposed to be fun, so don’t get too serious about it.


Hello @r.slegers and welcome to the Dexter Industries / ModRobotics user forum (to quickly help you understand where you are posting).

There is no “Grove” here.

For technical support with your GrovePi, please email support@modrobotics.com and the Dexter Industries / ModRobotics team will help you determine if a problem you are facing is a product issue or point you to appropriate documentation.


The Pi user is required for installation, but is not required to run the actual system after installation.
You can create it, install, and get rid of it.



Thanks Jimrh. Your information clarifies things a bit. I am ‘confusing’ my work environment with my playground and projecting some of it to there… Maybe too much… :wink:

Thanks cyclicalobsessive. I indeed thought that this was their support forum… Thanks for the email. I will send them an email about it.


Hi Cleo. Thanks for your response. That is exactly what I did… I re-created the pi user, installed the stuff and revoked the password of the pi user. Now it works as intended. :slight_smile:


So thank you all. It works now. I had to re-create the pi user to be able to install the stuff. Immediately after I revoked the password so everything is fine.

Now how do I close this? I looked for a button or so, but can’t find any…


This is their support forum.

However, there is no entity named “Grove”. Grove is a product, like the GoPiGo.

These fora are here to provide what support we can, hopefully taking some of the load off of the people at Modular Robotics/Dexter. They show up when they can, especially Cleqc, one of the engineers there.

Anything written by her, or cyclicalobsessive is well worth reading and will amply repay the time invested.

Feel free to stay, read, and if possible, provide what help and advice you can.

1 Like

The forum is a place for users to share their challenges and learnings. For actual support, use


where we can keep track and not drop any request. It’s too easy to miss a question on the forum.


This topic was automatically closed after 4 days. New replies are no longer allowed.