[SOLVED] Issue with Motors and Servos

gopigo3
#1

Hi,

I have a GoPiGo 3 and a Raspberry PI 3 with Raspbian Stretch 4.14. I have installed all the necessary software and libraries but motors don’t work when I try to run script examples like easy_Motors.py while all sensors and LEDs work very well. I have exactly the same issue with servos.

I don’t know if it’s from the power supply. I have 8AA 1.2V 1900mAh rechargeable batteries.

Thanks in advance for your help.

#2

Does the power button’s LED turn green when you plug in the battery while the Raspberry Pi is working?

#3

Yes, the power button flash green when I plug the battery.

#4

I still can’t get the engines running and I still can’t find any explanations… Yet, I installed the latest firmware and updated the software from github repository.

#5

Hi @kadox,

How did you install your GoPiGo3 on the Raspberry Pi? Did you install it with curl -kL dexterindustries.com/update_gopigo3 | bash or have you went with your own approach?

Seeing the power button flashing indicates that the GoPiGo3 power management service isn’t running on the Raspberry Pi - this can be caused by an improper installation.

There’s also the option of just using our Raspbian For Robots image instead of installing everything on your own. Here’s where you can find it:

Thank you!

#6

I installed the GoPiGo 3 with the first command, so I don’t know how the installation can be improper…

I think I will try on Raspian For Robot, I hope it will work.

#7

Indeed, the issue was due to the power management service like you said. So, I don’t need to install Raspbian For Robots. When I ran the gopigo3-power.py script in background, everything worked. Thanks for your help.

#8

So that was it. I’m glad to hear it fixed your problem. I’m now marking this thread as being solved.

Thank you!

closed #9

This topic was automatically closed after 40 hours. New replies are no longer allowed.